Apache won't start with no reason!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start with no reason!

Postby gilamran » 29. July 2009 22:48

Hi,
I've installed xampp and when I start Apache it will stop after two seconds.

  • I've checked the ports with xampp-portcheck.exe, and all the ports are free.
  • I've started the Apache in command line (apache.exe -k start) to see any error, and a weird error "[Sun !! :) "... YES a DOS smile!
  • I've closed all the programs, stopped any 3rd-party services, still nothing...
  • I've check the errors.log and I see "[Sun [Sun [Sun " WTF is that??? :x
    [/list]

I don't have any idea what's causing this problem... anyone!? H-E-L-P :!: :!: :!:

Thanks
Gil
gilamran
 
Posts: 3
Joined: 29. July 2009 22:33

Re: Apache won't start with no reason!

Postby Izzy » 30. July 2009 02:42

Gil, try and start Apache using the apache_start.bat file and paste back here any messages you receive - you can use the Edit functions by clicking on the little icon top left of the DOS Console Window.

After installing XAMPP did you restart your PC?

Did you try to install and uninstall XAMPP many times (more than once)?

In the XAMPP Control Panel click on SCM (Windows Service Control Manager) and see if there is an entry for Apache listed.

What OS and XAMPP version?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache won't start with no reason!

Postby gilamran » 30. July 2009 18:13

Izzy wrote:Gil, try and start Apache using the apache_start.bat file and paste back here any messages you receive - you can use the Edit functions by clicking on the little icon top left of the DOS Console Window.

* When I start apache_start.bat, after 5 seconds I get back to the command line with no error messages... nothing...

Izzy wrote:After installing XAMPP did you restart your PC?

Sure

Izzy wrote:Did you try to install and uninstall XAMPP many times (more than once)?

Sure!

Izzy wrote:In the XAMPP Control Panel click on SCM (Windows Service Control Manager) and see if there is an entry for Apache listed.

Nothing, no Apache service...

Izzy wrote:What OS and XAMPP version?

Windows XP SP2, XAMPP=1.7.1 Beta5
gilamran
 
Posts: 3
Joined: 29. July 2009 22:33

Re: Apache won't start with no reason!

Postby aj123cd » 31. July 2009 07:59

Have you edited httpd in conf folder?
aj123cd
 
Posts: 62
Joined: 03. June 2009 08:19
Location: London,UK

Re: Apache won't start with no reason!

Postby gilamran » 31. July 2009 11:03

no... why should I?
gilamran
 
Posts: 3
Joined: 29. July 2009 22:33

Re: Apache won't start with no reason!

Postby aj123cd » 31. July 2009 21:20

Httpd is apache configuration file; if you make unnecessary changes it will not allow you to start apache.
But it all in the learning process!
In the services apache and MySQL start-up type was selected manual, if you changed to automatic it will work.
apache control panel -> SCM -> apache -> right click properties -> start-up type -> select automatic
aj123cd
 
Posts: 62
Joined: 03. June 2009 08:19
Location: London,UK

Re: Apache won't start with no reason!

Postby wemseo » 01. August 2009 11:29

Hello

I have the exact same problem (as stated in this post at the very beginning)

YES - XAMPP Windows 1.7.1 ZIP install was successful.
YES - ports are available
YES - MySQL and FILEZILLA start running OK

Trying to start apache (with xampp or cmd... it just says "starting apache" but this message will never change to actually "apache started"!

I closed the cmd window (after 20 minutes), tried to start apache again and get an error ...
<OS 10048> Only one usage of each socket address >protocol/network address/port> is normally permitted. : make_sock: could not bind to address 0.0.0.0.:80 no listening sockets are available, shutting down

Well, that's funny, port 80 was free before. OK - I stop apache with the apache_stop.bat and try start again and now I wait again half an hour for apache to start. It never will!

NO - I haven't changed any setting or file or whatsoever. I only installed XAMPP, started it and everything seems running except apache and apache never will start running.

YES - I am totally lost :cry:

Cheers
wemseo
 
Posts: 9
Joined: 05. July 2009 20:54

Re: Apache won't start with no reason!

Postby Wiedmann » 01. August 2009 12:04

it just says "starting apache"

AFAIK that's all what you see with apache_start.bat. Only if there is an error you can see more.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache won't start with no reason!

Postby wemseo » 01. August 2009 12:55

Thanks

Ah ... I stopped, restarted, exit, start again and back and forth and VOILA ... all of a sudden Apache started :D how and through what action I can't really reenact but it started. Maybe it just needs a heck of time to wait ...

Cheers
wemseo
 
Posts: 9
Joined: 05. July 2009 20:54


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests