Does XAMPP 1.7.1 require .net framework?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 23. July 2009 17:05

Hi guys,

Had massive issues installing XAMPP today. I've tried numerous possible solutions, but none of them worked. Most issues and solution outlines are outlined here, in a blog post I found: http://www.jerrytravis.com/?p=268&cpage

^ The user in question seems to be suffering the same problem as me. Unfortunately his for me his solution hasn't worked for me.

I'm installing on a completely fresh machine (Win XP64), with newly updated software. This includes MS updates - which I fear may have something to do with my installation problems. If this is the case then there's a likelihood we'll be seeing many more similar posts to this one springing up over the coming weeks.

At present I'm just thinking about what I'm missing out of my setup from the last time I setup XAMPP - local testing server - on my machine. Presently I'm gathering the latest drivers for my hardware (shouldn't really have anything to do with things), and wondering if my MS updates have failed to install a .net framework on my machine...?

Is the .net framework essential for use of XAMPP??

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby Wiedmann » 23. July 2009 17:16

Had massive issues installing XAMPP today.

Which issues?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 23. July 2009 18:13

http://localhost or http://localhost/phpmyadmin won't load.

-Tried changing ports in the httpd.conf file (8080, http://localhost:8080).

-Tried disabling anti-virus n' win x64 firewall.

- Tried reinstalling

- Tried installing at C: & C: Program files.

- Numerous other fixes i've found online.

- Even tried installing WAMP! - same issue.

Having to resort to a Win re-install tomora :[

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby Wiedmann » 23. July 2009 18:24

http://localhost or http://localhost/phpmyadmin won't load.

But you can start Apache?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 23. July 2009 18:50

Yea, control panel says everything is running fine yea. Installed n' restarted it enough times today!

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 23. July 2009 18:55

Just spoke to a mate. Should i try installing 64-bit binaries (php & apache - can u get them)?

Apologies - replying from my phone.

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby Wiedmann » 23. July 2009 19:18

Yea, control panel says everything is running fine yea.

Can you access the server with "http://127.0.0.1/" instead of "http://localhost/"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 23. July 2009 19:25

No - pretty sure i tried an IP.

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby Wiedmann » 23. July 2009 19:30

won't load.

- What happens exactly? (behavior and maybe error message in your browser)
- error.log?
- access.log?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 23. July 2009 19:44

Hi,

Thanks for your help.

No browser error (in any browser i have installed, uncached too).

As far as access.log n' error.log - if you can tell where to find those i can provide the info.

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 24. July 2009 07:05

Heading into work this morning. Really need to get to the bottom of this.

Could anyone shed some light on how i might sucessfully update my XAMPP module binaries to 64-bit?

Cheers,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 24. July 2009 10:03

I have a feeling switching up the binaries from 32-bit to 64-bit will do it. As outlined in this post: viewtopic.php?t=28119

Hopefully it works. I will report back.

In the mean time tips/instruction for this process would be greatly received if anyone's familiar with this process.

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58

Re: Does XAMPP 1.7.1 require .net framework?

Postby ldexterldesign » 25. July 2009 05:08

Had to install Windows XP Professional 32-bit in the end. There was no solution to my problem.

Hope this saves the next person a day's worth of hassle. Roll on XAMPP 64-bit.

Thanks,
L
ldexterldesign
 
Posts: 21
Joined: 23. July 2009 16:58


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests