apache can't start after xampp upgrade + perl addon install

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache can't start after xampp upgrade + perl addon install

Postby mnem0 » 21. July 2009 00:30

Hi,
I just upgraded xampp 1.6.8 to 1.7.0 and then to 1.7.1.
After that i installed the xampp perl addon, all seemed fine, no error messages at upgrade/install

But, when i tried to launch apache from control-panel it didn't start ( i also checked in processes since i know this panel display is buggy).
So i decided to launch apachestart.bat.

I obtain
Code: Select all
httpd.exe: Syntax error on line 478 of c:/xampp/apache/conf/httpd.conf: Syntax error on line 7 of c:/xampp/apache/conf/extra/httpd-xampp.conf : API module struvture 'php5_module' in file C:/xampp/apache/bin/php5apache2.dll is garbled - expected signature 41503232 but saw 41503230 - perhaps this is not an apache module DSO, or was compiled for a different apache version ? Apache could not be started



here is line 478 of httpd.conf
Code: Select all
Include conf/extra/httpd-xampp.conf


here is line 7 of httpd-xampp.conf
Code: Select all
LoadModule php5_module "C:/xampp/apache/bin/php5apache2.dll"



Could someone help me please ?

thank you,
mnem0
mnem0
 
Posts: 12
Joined: 16. May 2008 19:32

Re: apache can't start after xampp upgrade + perl addon install

Postby Wiedmann » 21. July 2009 06:42

Code: Select all
LoadModule php5_module "C:/xampp/apache/bin/php5apache2.dll"

This must be:
Code: Select all
LoadModule php5_module "C:/xampp/apache/bin/php5apache2_2.dll"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests