403 error after modding httpd.conf [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

403 error after modding httpd.conf [SOLVED]

Postby mnem0 » 19. July 2009 06:34

hi,
i tried to enable perl execution in htdocs.

here are the changes i made to my httpd.conf file :
i changed the ScripAlias thing like this :
Code: Select all
ScriptAlias /cgi-bin/ "C:/xampp/htdocs/"


and i also modified this :

Code: Select all
# "C:/xampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "C:/xampp/htdocs">
   Options ExecCGI
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>


finaly i touched this :
Code: Select all
AddHandler cgi-script .cgi .pl


and now, when i try to access a .pl script located in htdocs, i got a 403 error.

note : my shebang i ok.

Could someone please help me, i'm a bit lost :(

bye,
mnem0
Last edited by mnem0 on 19. July 2009 15:51, edited 1 time in total.
mnem0
 
Posts: 12
Joined: 16. May 2008 19:32

Re: 403 error after modding httpd.conf

Postby Wiedmann » 19. July 2009 10:57

finaly i touched this :
Code: Select all
AddHandler cgi-script .cgi .pl

That's the only thing you must change. Don't change anything else.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 403 error after modding httpd.conf

Postby mnem0 » 19. July 2009 14:11

thank you for quick help Wiedman.

i followed your advices and reversed
Code: Select all
ScriptAlias /cgi-bin/ "C:/xampp/htdocs/"
to this
Code: Select all
ScriptAlias /cgi-bin/ "C:/xampp/cgi-bin/"


i also reversed
Code: Select all
<Directory "C:/xampp/htdocs">
   Options ExecCGI
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>


to this
Code: Select all
<Directory "C:/xampp/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>



now, i obtain a 500 error. do you know how to fix this ?

thank you again,

mnem0
mnem0
 
Posts: 12
Joined: 16. May 2008 19:32

Re: 403 error after modding httpd.conf

Postby Wiedmann » 19. July 2009 14:47

now, i obtain a 500 error. do you know how to fix this ?

Read the "error.log" what's the problem.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 403 error after modding httpd.conf

Postby mnem0 » 19. July 2009 14:52

well, it is quite obscure for me. i already had done this. here are the errors :
Code: Select all
[Sun Jul 19 15:07:20 2009] [error] [client 127.0.0.1] (OS 5)Acces denied.  : couldn't create child process: 720005: archivesic.pl
[Sun Jul 19 15:07:20 2009] [error] [client 127.0.0.1] (OS 5)Acces denied.  : couldn't spawn child process: C:/xampp/htdocs/archivesic.pl


note : the script used to run on another server, the code is ok.
the shebang is good too.

any idea ?

thank you for all your help, you're very kind.

mnem0
mnem0
 
Posts: 12
Joined: 16. May 2008 19:32

Re: 403 error after modding httpd.conf

Postby Wiedmann » 19. July 2009 14:59

the shebang is good too.

Shure?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 403 error after modding httpd.conf

Postby Nobbie » 19. July 2009 15:01

mnem0 wrote:the shebang is good too.


How can we know that? Please, show us the shebang line (copy&paste).
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: 403 error after modding httpd.conf

Postby mnem0 » 19. July 2009 15:04

here it is :
Code: Select all
#!c:\xampp\perl\bin -w


thank you for your great help :D

mnem0
mnem0
 
Posts: 12
Joined: 16. May 2008 19:32

Re: 403 error after modding httpd.conf

Postby Wiedmann » 19. July 2009 15:11

here it is :

Should be:
Code: Select all
#!c:\xampp\perl\bin\perl.exe -w
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 403 error after modding httpd.conf

Postby mnem0 » 19. July 2009 15:13

what a lamer.
really sorry for wasting your time.
you solved it. a great thank you for you.

mnem0
mnem0
 
Posts: 12
Joined: 16. May 2008 19:32


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests