I can't change apache port with Xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I can't change apache port with Xampp

Postby Dav1d » 18. July 2009 15:51

Hello

I've just installed xampp and I want to change apache port from 80 to 8080, I've opened httpd.conf file locate in C:\xampp\apache\conf, and I change to lines,

#Listen 12.34.56.78:80
Listen 8080

and
ServerName localhost:8080

but When I try to run apache with xampp, it still look for port 80 and doesnt' start.

I am more than an hour google for a solution, but I have a right answer that how to change the port and it works fine.

Thanks in advance

David
Dav1d
 
Posts: 3
Joined: 18. July 2009 15:46

Re: I can't change apache port with Xampp

Postby Wiedmann » 18. July 2009 16:28

and doesnt' start.

Why not?
--> error message
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: I can't change apache port with Xampp

Postby Dav1d » 18. July 2009 16:38

there's no error message, just when I press start on xampp, it writtes : Apache started [Port 80], but port 80 it doesn't be yet in httpd.conf. What I don't know it's why Xampp still tries to start on 80 instead of 8080.
Dav1d
 
Posts: 3
Joined: 18. July 2009 15:46

Re: I can't change apache port with Xampp

Postby Wiedmann » 18. July 2009 17:20

there's no error message, just when I press start on xampp,

Start Apache with the batchfile and read the error message.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: I can't change apache port with Xampp

Postby Dav1d » 18. July 2009 17:39

Hi again

I've investigated, and when a I put port 7070 or 8080, I run with the bath file ,and it say me port 443 it's busy. I have in skype the option to listen for por 80 and 443, if I shut off skype it works, but I wonder if I put port 7070 or 8080, what does it say me port 443 it's busy ? Witch port I can write in httpd.conf with doesn't anything to do with port 80 or 443.
Dav1d
 
Posts: 3
Joined: 18. July 2009 15:46

Re: I can't change apache port with Xampp

Postby Wiedmann » 18. July 2009 18:02

what does it say me port 443

Port 443 is configured for HTTPS in "httpd-ssl.conf".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests