xampp vs vista on laptop

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp vs vista on laptop

Postby shrg18 » 10. July 2009 04:17

I installed xampp 7.0 on my laptop, Compaq, months ago and it ran well. I didn't use this laptop for months after xampp had been installed .

Now I work on this laptop and found this error message:
------------------------------------------------------------------------
Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500
localhost
07/09/09 23:09:55
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9
---------------------------------------------------------------------------

The testing script is simple:
Code: Select all
printf("kkkkk");


I deleted xampp 7.0 from C: and installed xampp 7.1, thought the latest version would eliminate all potential problems. But wouldn't work this way.

In brief, with vista, xampp worked fine before, it doesn't work now.

what should I do to solve this error?
shrg18
 
Posts: 43
Joined: 16. August 2007 13:59
Location: windsor, on, canada
Operating System: windows 8

Re: xampp vs vista on laptop

Postby Wiedmann » 10. July 2009 07:19

what should I do to solve this error?

Read the "error.log".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: xampp vs vista on laptop

Postby shrg18 » 10. July 2009 12:32

Wiedmann wrote:
what should I do to solve this error?

Read the "error.log".

The problem is solved.

I went to apache/logs/error.txt and read:
-----------------------------------------------------------------
[Fri Jul 10 07:17:45 2009] [alert] [client 127.0.0.1] C:/xampp/htdocs/a125/.htaccess: Invalid command 'suPHP_ConfigPath', perhaps misspelled or defined by a module not included in the server configuration
-----------------------------------------------------------------

Remove .htaccess from the directory. It works.

.htaccess was downloaded from the web server.

Thank you.
shrg18
 
Posts: 43
Joined: 16. August 2007 13:59
Location: windsor, on, canada
Operating System: windows 8


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests