MySql - Cannot connect: invalid settings.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySql - Cannot connect: invalid settings.

Postby jovemac » 02. July 2009 19:28

Hi!

I am new to php. For learning purposes i installed xampp. Wheni opened phpmyadmin, it said that root is left open without a password. I do changed the password for root@localhost and root@127.0.0.1. Thought both are same and gave the same password for both. Now i am getting the error message as below.

MySQL said: Documentation
Cannot connect: invalid settings.

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

Please advise.

Regards - Jo
jovemac
 
Posts: 2
Joined: 02. July 2009 19:19

Re: MySql - Cannot connect: invalid settings.

Postby Wiedmann » 02. July 2009 20:19

You must also adjust the password in "config.inc.php".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySql - Cannot connect: invalid settings.

Postby agiles » 14. March 2011 13:01

Alright I found a fix.

because of xampp server had the following settings. go to this directory C:\xampp\phpMyAdmin\config.inc.php

$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = ''; // which is default setting in xampp server

and now u have to change this default null password to your password
$cfg['Servers'][$i]['password'] = 'your password';//type your password
agiles
 
Posts: 1
Joined: 14. March 2011 12:58

Re: MySql - Cannot connect: invalid settings.

Postby xfsgpr » 14. March 2011 14:02

agiles wrote:Alright I found a fix.

because of xampp server had the following settings. go to this directory C:\xampp\phpMyAdmin\config.inc.php

$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = ''; // which is default setting in xampp server

and now u have to change this default null password to your password
$cfg['Servers'][$i]['password'] = 'your password';//type your password


My configuration file has the following entries:

$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = false;

No problems here logging in to MySql server. It is an automatic process.
xfsgpr
 
Posts: 27
Joined: 20. August 2009 21:45


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests