PHP Version lower than 5.0.0 is required

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP Version lower than 5.0.0 is required

Postby gudduhassan » 02. July 2009 06:31

i m installing an application,its installation requires this thing please help me resolving the issue i m currently using XAMP server with php 5.2.8 running
gudduhassan
 
Posts: 1
Joined: 02. July 2009 06:27

Re: PHP Version lower than 5.0.0 is required

Postby Wiedmann » 02. July 2009 08:13

My recommendation?
--> Don't install an app with such a requirement.

(you can install an older XAMPP (1.6.9) which have a switch to PHP4)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: PHP Version lower than 5.0.0 is required

Postby aldo » 02. July 2009 22:26

What application is it..?

I would have to agree with Wiedmann... That application must be really bad (No offense!) to not have built in support for PHP5. :roll:
aldo
 
Posts: 13
Joined: 17. July 2008 08:10

Re: PHP Version lower than 5.0.0 is required

Postby damiand » 09. August 2009 10:40

Hmmm now I understand - so anything written in PHP4 or earlier is bad - this sort of terrible code should be immediately chucked in the bin I think - let's dump all those large PHP4 based systems out there too even though they have been performing safely and securely since the dark ages when they were produced by evil creatures working in dens of ignorance and unprofessionalism - wow I wish I had understood how evil PHP4 was beforehand, I would have waited until PHP5 came along before developing anything. Hmm I also perhaps hadn't realised that is was not possible to write bad or unsecure code in PHP5 either!! Thanks for saving the world for us all :roll:

Oh yes - you mentioned V1.6.9 - I think you might just find 1.6.8 is the latest with PHP4 for Windows you could get it here http://sourceforge.net/projects/xampp/files/
damiand
 
Posts: 2
Joined: 09. August 2009 10:21

Re: PHP Version lower than 5.0.0 is required

Postby aldo » 11. August 2009 07:14

It's not that you can't write insecure code on PHP 5 too, you certainly can... However more people will begin to use PHP 5, and if your code base is explicitly PHP 4, all your user base is gone, and your system is as good as dead...

Though I personally don't quite understand how you can write code that isn't compatible with PHP 5 that was coded in PHP 4 originally because PHP 5 has all that PHP 4 does, in fact, more so. Unless of course the creator did something weird, very weird.
aldo
 
Posts: 13
Joined: 17. July 2008 08:10

Re: PHP Version lower than 5.0.0 is required

Postby damiand » 12. August 2009 09:53

@aldo

Hi There - I guess my posting was a bit tongue in cheek - however I think the point stands that if you have a code base of say 1.5 million lines for a system that was written originally for PHP4 then the sheer size of the task including all the data migration and testing for a significant revision is something that has to be carefully considered. I agree that over time it would be a good thing to do, however my call really is to suggest that it is not always possible to generalise and sometimes the sheer practicality and costs associated with a task may prohibit or delay progressing it.

On the PHP4 to PHP5 subject actually there are a number of things that may give rise to problems running good quality well written PHP4 code on a PHP5 system. One of the key areas is the change in the object model and an important change here is that in PHP4 everything was passed by value (including objects). In PHP5 this changed to being passed by reference. Great if your PHP4 code is not affected, however if you were writing substantially OO in 4 then you may have some difficulties with 5 in this and other areas e.g. to copy an object you need to use clone in php5 in order to get a full copy - again this may not affect you, but in a large codebase that was produced by a team who may not all now be available to assist this would have to be checked out before migrating to 5 and it could be a massive task just to undertake a proper code review.

Another example of an area that could cause problems is the use of get_x() - it always returns lowercase in PHP4 and in 5 will return the actual name - so using get_class() on the class CamelCaseClass returns camelcaseclass in 4 and in 5 CamelCaseClass - again may or may not be an issue for you. There is a useful page on php.net which covers some of the backward compatibility issues - the implications are actually potentially much further reaching than may initially be obvious. http://php.net/manual/en/migration5.incompatible.php

Hope this is of some help to people and thanks aldo for taking the time to reply.
damiand
 
Posts: 2
Joined: 09. August 2009 10:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests