Multiple Joomla Installations not Working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Multiple Joomla Installations not Working

Postby paul_j » 01. July 2009 01:47

Hi,

I am experiencing troubles with XAMPP when I try and run two of the same Joomla websites. I have them both in different folders in htdocs, but when I edit one, it edits the other one too and messes it up. Why should this be happening?

I tired deleting my cache and it did not make any difference -> the latest Joomla installation was always the one that worked best and the previous one would the stop working?

My ideas are:
[list=]Install xampplite on different hard drives and install each similar Joomla website there.[/list]
[list=]Work one at a time (VERY inconvenient)[/list]
[list=]Find out if there is an issue with the MYSQL database[/list]


Your support is most appreciated.
paul_j
 
Posts: 5
Joined: 01. July 2009 01:39

Re: Multiple Joomla Installations not Working

Postby glitzi85 » 03. July 2009 19:07

I hope you used two different Databases during the joomla installations or at least a different prefix! Otherwise you need to reinstall one joomla, using another database.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Multiple Joomla Installations not Working

Postby paul_j » 04. July 2009 02:07

Hi,

Yes, when installing joomla I used:

localhost
root
//No password
database name: some random letters.

Is this correct or should I set up the mysql databases with XAMPP somewhere first?
paul_j
 
Posts: 5
Joined: 01. July 2009 01:39

Re: Multiple Joomla Installations not Working

Postby glitzi85 » 04. July 2009 15:50

paul_j wrote:Hi,

Yes, when installing joomla I used:

localhost
root
//No password
database name: some random letters.

Is this correct or should I set up the mysql databases with XAMPP somewhere first?

Did you use the same settings (including the random letters) for BOTH Installations?

Could you please log into phpMyAdmin (http://localhost/phpMyAdmin) and select the SQL Tab and execute this command:

Code: Select all
SHOW DATABASES;


Then post the output here.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Multiple Joomla Installations not Working

Postby paul_j » 06. July 2009 00:52

Sorry, but that link you gave me gives an error 404.

XAMPP IS working because I can access http://localhost/xampp/ without any problems. What do you suggest I do?
paul_j
 
Posts: 5
Joined: 01. July 2009 01:39

Re: Multiple Joomla Installations not Working

Postby paul_j » 06. July 2009 01:01

Hi,

I found the link you were referring to through XAMPP localhost home. Yest is shows lots of different databases (23).
paul_j
 
Posts: 5
Joined: 01. July 2009 01:39

Re: Multiple Joomla Installations not Working

Postby glitzi85 » 06. July 2009 04:54

Sorry, didn't have an original XAMPP up and running, so could not post the right link. Would be http://localhost/phpmyadmin

Could you please post the result of the SQL Command I posted.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests