PHP using MySQL 5.0.51a client instead of 5.1.32

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP using MySQL 5.0.51a client instead of 5.1.32

Postby NiteShdw » 22. June 2009 22:41

I just upgraded my XAMPPLITE installation to 1.7.1. I see that 1.7.1 comes with MySQL server 5.1.33. However, PHP (via phpinfo.php) shows that it's using the client version 5.0.51a.

I found in the /php and /php/ext folders that there are two copies of the MySQL libraries. I renamed the "_5.1.32.dll" libraries to just "php_mysql.dll" and I did the same with the "libmysql.dll" file. How, PHP is showing that it's still using client version 5.0.51 but the "header" version is 5.1.32.

I would prefer to have my PHP client running the same version as the server. Can anyone help?
Posts: 1
Joined: 22. June 2009 22:37

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests