Apache crashes everytime I try to start it...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache crashes everytime I try to start it...

Postby khas » 19. June 2009 15:34

Hi folks!

I have a strange problem.
When I start Apache, it crashes in several seconds! I searched for a solution with Google, but nothing I found worked for me. I tried to rearrange the port which Apache "listens" to, tried to reinstall XAMPP, and even Apache separately, but nothing proved to be succesful.

The error.log file shows this:

Code: Select all
[Fri Jun 19 16:23:49 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Jun 19 16:23:49 2009] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 19 16:23:49 2009] [notice] Digest: done
[Fri Jun 19 16:23:50 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 configured -- resuming normal operations
[Fri Jun 19 16:23:50 2009] [notice] Server built: Dec 10 2008 00:10:06
[Fri Jun 19 16:23:50 2009] [error] (OS 2)The system cannot find the file specified.  : Parent: Could not set child process stdout
[Fri Jun 19 16:23:51 2009] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 19 16:23:51 2009] [notice] Digest: done
[Fri Jun 19 16:23:53 2009] [notice] Child 2388: Child process is running
[Fri Jun 19 16:23:53 2009] [crit] (OS 109)The pipe has been ended.  : Child 2388: Unable to retrieve the ready event from the parent


I'm using the newest XAMPP installation 1.7.1, under Windows XP SP3. Tried to start Apache alone, but the result was the same. Once I stoped it with "NET STOP Apache" from Windows command line, than tried to restart it with "NET START Apache", but again: nothing, it crashed.

The Windows error message is the following:
Code: Select all
AppName: httpd.exe    AppVer: 2.2.11.0    ModName: libapr-1.dll
ModVer: 1.3.3.0    Offset: 000084ad


Please, help me if you can!
Thanks in advance!
Khas
khas
 
Posts: 3
Joined: 19. June 2009 15:25

Re: Apache crashes everytime I try to start it...

Postby DekaMastah » 10. July 2009 04:00

I'm also experiencing the same problem but I'm using Windows XP Pro SP2.

I've used different versions (1.5, 1.6., 1.7) and it still doesn't work.

Here are some screenshot:

Image
Image

Event Viewer:
Image

Port Check:
Image

I've disabled all start-up programs as well as other background services that might interfere with Apache but still the error comes up. I'm guessing this is Windows-related but I don't really know.

Anybody else here encounter this problem?
DekaMastah
 
Posts: 1
Joined: 10. July 2009 03:36

Re: Apache crashes everytime I try to start it...

Postby roman2 » 14. July 2009 00:00

I've had Apache crash on my computer too (Windows Vista). It used to crash with WAMP too. Not every time it had to serve a request but too often to make developing comfortable. I've tried different things (I switched to XAMPP for this reason, but it didn't help), but none have helped. What has helped is to run PHP in CGI mode (Fast CGI, to be more accurate) as opposed to as an Apache module. It doesn't seem to ever crash since I switched to CGI mode.
roman2
 
Posts: 17
Joined: 03. July 2009 15:56
Operating System: 32-bit Windows 7

Re: Apache crashes everytime I try to start it...

Postby hidonet » 18. August 2009 01:48

I think This problem affecting only apache 2.2
I've installed Vertrigo, it has apache 2.0 and working.

But I want to install Xampp
hidonet
 
Posts: 2
Joined: 18. August 2009 01:31

Re: Apache crashes everytime I try to start it...

Postby Izzy » 18. August 2009 02:27

Most often you have used the installer in older versions of XAMPP which in XP has been known to give some unexplainable issues.

Using the \xampp\apache_start.bat file will often give feed back why apache can't start



Try this method to prepare for a fresh install from scratch using the 7zip self extracting archive version.

Make sure that you have stopped all running XAMPP components either from the Control Panel or by using the bat files provided for this task.


Go to the \xampp\apache folder and run the apache_uninstallservice.bat file.

Go to the \xampp\mysql folder and run the mysql_uninstallservice.bat file.

Now to make sure we have no sticking services, open a command prompt:
Click on start
Click on Run...
Type sc delete apache2.2
Click OK

Now type sc delete mysql
Click OK

Close the command prompt.


Next to check all is safely removed right click on the Task Bar and select Task Manager>Processes and look for any apache or mysql processes running and click on End Process after highlighting any you find, click Yes when asked then close out.

Next open the service manager, click on start>Administrative Tools>Services and in the list of services again look for any apache or mysql services - there should be none after doing the above 2 removal methods.


Now you can delete the xampp installation folder completely.


For versions prior to 1.7.2 (the current stable) download and extract the 7zip exe file into C:\ drive which will create C:\xampp folder. Then run the setup_xampp.bat file then start the Control Panel and run Apache and MySQL.

For the current 1.7.2 version download the exe (self extracting) installation version and double click on it then follow the instruction in the setup file presented or if you prefer you can still follow the instructions above for earlier versions as the new 1.7.2 version is also an archive file that can be opened with 7zip or the rar archive utility and manually extract the files to C:\xampp and then run the setup_xampp.bat file.


For XP users the above methods have often fixed the installation and starting of Apache issues and you can also try restarting your PC after installing XAMPP which has also helped.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Apache crashes everytime I try to start it...

Postby hidonet » 29. September 2009 15:24

I think your solution is not works.. This problem is about libapr-1.dll. Libapr-1.dll is crashing after xp sp3 and problem still not solved or patched..
hidonet
 
Posts: 2
Joined: 18. August 2009 01:31

Re: Apache crashes everytime I try to start it...

Postby Izzy » 30. September 2009 01:55

hidonet wrote:I think your solution is not works.. This problem is about libapr-1.dll. Libapr-1.dll is crashing after xp sp3 and problem still not solved or patched..
Perhaps my solution doesn't work for you but without any details of your issue it would be impossible to deduce that it is one thing or another.

So how about some details so at least your issue can be looked at...

...but as always if we don't hear back from the OP of the topic to tell us if any solution presented here has been effective then one can only assume success and move on - this posting back after being helped on this forum is very important and may have eliminated any need for some of the replies here.

It is just as important to always include the XAMPP version installed and on which Windows OS as any one of these factors can have differing effects on any perceived issues.

BTW I have several instances of different versions of XAMPP on my XP PC with no libapr-1.dll issues at all, so the assumption is that it is the state of an individual's PC rather than an issue with the individual components of a particular set of combined scripts and apps.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests