suddenly Cannot load mysql extension after connecting via IP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

suddenly Cannot load mysql extension after connecting via IP

Postby sta4 » 19. June 2009 11:17

I have read dozens of Cannot load mysql extension but none answered my problem...

Windows Vista
XAMPP Version 1.7.1
PHP: 5.2.9

I have been working and designing my joomla site for 2 weeks now.
today i tried to connect via my IP to see if it can be entered from out of my local pc.
i turn on the FILEZILLA SVC from the xampp panel (I think for the first time)
then tried to connect through IP in the browser.
since then i have an error message and cannot enter my site, or the sql database...
it says: Cannot load mysql extension. Please check your PHP configuration. - Documentation.
Apache and MySQL are running according to the XAMPP panel.

i also remeber that when first saw the welcome to XAMPP (entered by IP) it also said : if you see this then your xampp installed correctly.
when i enter from localhost i can only see Version 1.7.1 ! in the come page.
I dot have any other php.ini other than the one in php directory , though i wish i had when i see it fixed to everyone their problem...

please try to hlp me get my site up again...
i'm afraid to lose my data...


:idea:
Ok fixed it.
I allowed some extensions like extension=msql.dll to work in php.ini
so all is good now.
no idea what caused the problem

but now it can't open a php sciprt from the localhost in the browser...
it shows a 500 internal problem...
what should i do now ?
sta4
 
Posts: 2
Joined: 19. June 2009 11:00

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests