correct php version in xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

correct php version in xampp

Postby hem » 18. June 2009 13:33

hi all, i am learning php. i use xampp1.7.1 with phpdesigner6.2.5 on vista platform. My problem is when i write a class like Employee() and define a constructor using the _construct() syntanx, it isnt getting processed instead if i use the old php4 style constructor syntax like public function Emplyoee(), then its getting perfectly excuted. I'm at my wits end to know where is what going wrong. also i searched for php-switch.bat file and it seems that file missing from installation. Please help. Thanks.
hem
 
Posts: 7
Joined: 18. June 2009 13:08

Re: correct php version in xampp

Postby Wiedmann » 18. June 2009 13:44

The example in the manual is working without problems for me...
http://de.php.net/manual/en/language.oo ... onstructor
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: correct php version in xampp

Postby hem » 18. June 2009 16:18

Extremely sorry... i found out the problem after i copy paste and run the programme . Previously i used to use only a single underscore before the construct() syntax as can be seen from my first post. Thnx very much for the clarification. :D
hem
 
Posts: 7
Joined: 18. June 2009 13:08


Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf, JJ_Tagy and 61 guests