Problem with running httpd on port 8080

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with running httpd on port 8080

Postby divick.kishore » 10. June 2009 14:06

Hi
I have downloaded the 1.7.1 and installed it on my windows machine with XP and Service Pack 3. When I start the apache server, I see that it does not start. I have read in the FAQs for XAMPP for windows that windows firewall can block port 80 and thus either the firewall needs to be disabled or the port need to be changed.

Unfortunately I can install software on my machine, but I cannot disable the firewall as I am not the administrator of the machine. I have tried changing the port in the httpd.conf but to no avail...I see that my browser cannot connect to http://localhost at port 8080. But when I connect to http://localhost, I get a blank page. Now I am not sure why changing the httpd.conf file (Listen 8080 and ServerName localhost:8080) doesn't make the apache run the server with port 8080.

Is there any other way to change the listening port for the apache server?

Any help is appreciated,
Thanks in Advance,
Divick
divick.kishore
 
Posts: 2
Joined: 10. June 2009 13:56

Re: Problem with running httpd on port 8080

Postby larryleblanc » 10. June 2009 21:48

Hi Divick,
I am having a similar problem. I cannot get apache to run. I did have it running and did an uninstall as I was just testing things out then re-installed and put everythign on an external drive; after the re-install I've had Apache startup problems. I tried changing the port to 8080 in the conf file and that did not work.

When I do a netstat to get the port status I do not get 80 in the list so I guess it's blocked by Windows XP. I do have my Windows Firewall turned off, so I don't understand why it is blocked.

BTW: when I did the uninstall, is was not a clean uninstall. I had to manually uninstall the following services: apache2.2 and mysql

Help.
Larry LeBlanc
larryleblanc
 
Posts: 2
Joined: 10. June 2009 21:37

Re: Problem with running httpd on port 8080

Postby newbie2244 » 11. June 2009 00:37

Greetings-

1. Assuming that you are on Windows, remember that you may have to reboot your system after making changes to any .config or .ini files.

2. Under the toplevel xampp dir you should find a "* portcheck.exe" file. Click on that file to get a listing of ports & their assignments. That should tell you what application is currently bound to which port. Do you have any add-ons, like Tomcat or the infamous Skype or Wordpress? If so, to which ports are they bound?


3. If you installed and then uninstalled, you may not have done so completely or cleanly, as mentioned above. When I had a similar problem, I had to manually delete xampp path entries from Windows registry and reboot. I then re-installed a fresh copy of xampp. I used the installer version the second time and had no problems. On the subject of rebooting, do a hard reboot. In general, once you have something installed and working, don't (practice) uninstalling and reinstalling. Unpredictable outcomes occur on Windows.

4. Regarding the firewall, you don't have to turn it off on Windows; you might be able to just lower the level of security from high to low on your personal account. If you are able to download and install xampp then probably this is not the problem.

5. If you uninstall parts of xampp, and then re-install those parts in a location other then where they were originally, check path entries in the Environment Variables AND in your Registry to be sure that all path entries are correct and correctly updated.

6. Search apache_friends_forum archive files for possible solutions to the same problem that you are having. Good suggestions have been given, in the past, to the type of problems both of you describe. Enter keywords "like port 80, port 8080 httpd.config . . ." etc.

Regards-
newbie2244
 
Posts: 49
Joined: 20. February 2009 22:39

Re: Problem with running httpd on port 8080

Postby larryleblanc » 11. June 2009 01:30

That was quite helpful actually. The port check showed where the problem is.
It showed that Apache <WebDAV> is looking for Port 81 and Apache <HTTPS> is looking for Port 82..And both ports are being used by inetinfo.exe.
Port 80 is free though.

Is there a way to change the port assignment for Apache <WebDAV> and Apache <HTTPS>?
larryleblanc
 
Posts: 2
Joined: 10. June 2009 21:37

Re: Problem with running httpd on port 8080

Postby divick.kishore » 15. June 2009 18:38

Hi,

newbie2244 wrote:Greetings-

1. Assuming that you are on Windows, remember that you may have to reboot your system after making changes to any .config or .ini files.

2. Under the toplevel xampp dir you should find a "* portcheck.exe" file. Click on that file to get a listing of ports & their assignments. That should tell you what application is currently bound to which port. Do you have any add-ons, like Tomcat or the infamous Skype or Wordpress? If so, to which ports are they bound?


3. If you installed and then uninstalled, you may not have done so completely or cleanly, as mentioned above. When I had a similar problem, I had to manually delete xampp path entries from Windows registry and reboot. I then re-installed a fresh copy of xampp. I used the installer version the second time and had no problems. On the subject of rebooting, do a hard reboot. In general, once you have something installed and working, don't (practice) uninstalling and reinstalling. Unpredictable outcomes occur on Windows.

4. Regarding the firewall, you don't have to turn it off on Windows; you might be able to just lower the level of security from high to low on your personal account. If you are able to download and install xampp then probably this is not the problem.

5. If you uninstall parts of xampp, and then re-install those parts in a location other then where they were originally, check path entries in the Environment Variables AND in your Registry to be sure that all path entries are correct and correctly updated.

6. Search apache_friends_forum archive files for possible solutions to the same problem that you are having. Good suggestions have been given, in the past, to the type of problems both of you describe. Enter keywords "like port 80, port 8080 httpd.config . . ." etc.

Regards-


Thanks for the reply. I found that when I quit skype, I see no problem occurs. But it is strange that even though I configured apache to run on port 8080, still it has conflicts with skype. Also no matter what port the apache is configured to run on, it always shows 80 in the control panel for xampp. Any suggestions about these problems?

The output of the portcheck is as shown below:

Service Port Status
==============================================================================
Apache (HTTP) 80 C:\Program Files\Skype\Phone\Skype.exe
Apache (WebDAV) 81 free
Apache (HTTPS) 443 C:\Program Files\Skype\Phone\Skype.exe

MySQL 3306 free

FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free
divick.kishore
 
Posts: 2
Joined: 10. June 2009 13:56

Re: Problem with running httpd on port 8080

Postby newbie2244 » 15. June 2009 22:54

Greetings-

Read this thread . The version of xampp that is used is 1.7.0 but the approach is still the same.
viewtopic.php?f=16&t=34399&p=140010&hilit=apache+on+port+8080#p140010

Regards-
newbie2244
 
Posts: 49
Joined: 20. February 2009 22:39


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests