XAMPP 1.71 on Vista won't allow the CP to run as a service

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.71 on Vista won't allow the CP to run as a service

Postby DynV » 09. June 2009 02:38

XAMPP 1.71 (basic package) on Vista Home premium (Version 6.0 Build 6001: Service Pack 1) won't allow the Control Panel (CP) to run as a service. The installation that I've used up to now, default control panel with it's features (Apache, Mysql, FTP) running as service, seems to work just fine however I won't be developing as much with this setup so won't need XAMPP to be loading all the time thus I'd like to load it as needed.

I could make batch file (.bat) stopping and starting the services but why not use the feature already bundled with it that allow me to load the CP as a service attaching the features with it. I've tried many times (after rebooting) to load the CP as a service with and without features attached unsuccessfully. I even tried running the generated line of command through SC command but I keep getting the error [SC] OpenSCManager FAILED 5: Access is denied.

I've just uninstalled XAMPP and ran the installer to see if there's option to run the CP as a service right from the start but haven't found it. Is there a special way to install XAMPP that would help me running the CP as a service or debugging why I get the SC error message ?

Thank you
User avatar
DynV
 
Posts: 3
Joined: 09. June 2009 02:19
Location: Montreal, Canada

Re: XAMPP 1.71 on Vista won't allow the CP to run as a service

Postby aj123cd » 09. June 2009 15:58

The solution is:
Go to the Services window (Control Panel - Administrative tools - Services)

Check the Apache listing there (mine is Apache2.2). See if the status is disabled. If it is right click on your Apache listing and go to properties. Change the start up type to Automatic or Manual as you require.
Click on apply or ok.

Then when you are back in the services window you can start the service right here by right clicking and the Start or else you can start the service from the Control Panel

Note: This will work only if your port is not in use by any other service/application
aj123cd
 
Posts: 62
Joined: 03. June 2009 08:19
Location: London,UK

Re: XAMPP 1.71 on Vista won't allow the CP to run as a service

Postby DynV » 09. June 2009 16:40

aj123cd wrote:The solution is:
Then when you are back in the services window you can start the service right here by right clicking and the Start or else you can start the service from the Control Panel


aj123cd this was already mentioned as a possibility in the second paragraph of my original post ... I need the Control Panel to start as a service, not it's features (Apache, Mysql, FTP). I need a quick way to start and stop XAMPP completely, this can be through CP integrated system, a batch file, anything else as long as with 1-2 click (when I won't have a use for it anymore) I can have XAMPP not hogging my CPU and RAM.

Thank you for paying attention to my problem.
User avatar
DynV
 
Posts: 3
Joined: 09. June 2009 02:19
Location: Montreal, Canada

Re: XAMPP 1.71 on Vista won't allow the CP to run as a service

Postby aj123cd » 09. June 2009 17:06

Now I have tried a different method; I have copied the folder xampp from c drive and save it on the desktop or u can save where ever you like.
Uninstall the xampp and restart the program, just double check the c drive and no xampp.
Then just copy/cut the xampp from the desktop and place it in the c drive.
Open the xampp folder and start the XAMPP control panel.
Check to see local host is working.
pl let me know .
aj123cd
 
Posts: 62
Joined: 03. June 2009 08:19
Location: London,UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests