phpMyAdmin Access Denied

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin Access Denied

Postby lillytee » 02. June 2009 13:21

Hello,

I've tried some solutions listed for my issue and have not found a working solution yet. My XAMPP install has worked great for years and I have had no issue with phpMyAdmin or mySQL at all until the last few days. I installed Form Tools (which I believe automatically created a db) on the 28th and Syntype (manually created the db) on the 26th. Syntype would not complete the install without a password for it's db. I set one via phpMyAdmin. I have no passwords for any other db's or for accessing mySQL itself.

My error is the 1045 (xampp phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection..). My config is:
$cfg['Servers'][$i]['auth_type'] = 'config'; // Authentication method (valid choices: config, http, HTTP, signon or cookie)
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = '';

I tried using cookie, cleared cache files, with no luck. Same for entering a password. I also tried deleting the syntype folder, thinking that was the culprit since I had a little trouble installing it. I haven't upgraded XAMPP or done anything else in a while besides install those two scripts.

Any ideas?
lillytee
 
Posts: 2
Joined: 02. June 2009 13:09

Re: phpMyAdmin Access Denied

Postby Wiedmann » 02. June 2009 20:44

Syntype would not complete the install without a password for it's db. I set one via phpMyAdmin.

How have you done this, and for which user?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: phpMyAdmin Access Denied

Postby lillytee » 03. June 2009 03:28

Wiedmann: yes, and for root.

I went back and attempted to reinstall both scripts just to review the install process of each again. It was actually Form Tools that insisted on a password. I set one via it's install page (the other day) with root as the user. So now I see that my total access is affected -- now requiring a pw to access mySQL itself. Maybe that was a good time to create a new user. I am just used to the root/no password with all installs going smoothly, so this threw me.

I put the password in the config file and gained access to the db via phpmyadmin. Now I have gone to Privileges and chosen "no password" and hope I am back to normal now.

Thank you for your help.
lillytee
 
Posts: 2
Joined: 02. June 2009 13:09


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests