Help with windows server 2003 sp1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help with windows server 2003 sp1

Postby sileng » 02. June 2009 04:44

i installed xampp did everything right and stuff and when i try to go to the main page of my website it doesn't load...all it say is waiting...please if anyone know how to solve this problem i would i appreciate it..
sileng
 
Posts: 6
Joined: 02. June 2009 04:38

Re: Help with windows server 2003 sp1

Postby Sharley » 02. June 2009 04:47

What do you see when you go to:
http://localhost
and
http://127.0.0.1

Be aware that for anyone to troubleshoot your issues you have to relay as much detail as possible about what you are doing, what you have done already and what you see on your monitor.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with windows server 2003 sp1

Postby sileng » 02. June 2009 04:54

it says its underconstruction...i changed the port because it was being used by IIS so i used port 8080 no when i type "myip:8080" it only says waiting for "myip"...by the way i use mozilla for this..
sileng
 
Posts: 6
Joined: 02. June 2009 04:38

Re: Help with windows server 2003 sp1

Postby Sharley » 02. June 2009 04:57

What do you see when you type:
http://localhost:8080
and
http://127.0.0.1:8080

Please try and answer my questions exactly and with details as they are important steps to troubleshoot your issue
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with windows server 2003 sp1

Postby sileng » 02. June 2009 04:59

also i updated windows server 2003 sp1 with all the updates that microsoft provided. if that makes a difference.
sileng
 
Posts: 6
Joined: 02. June 2009 04:38

Re: Help with windows server 2003 sp1

Postby Sharley » 02. June 2009 05:22

sileng wrote:also i updated windows server 2003 sp1 with all the updates that microsoft provided. if that makes a difference.
It may make a difference and is what we are trying to ascertain by Q&A.
Sharley wrote:What do you see when you type:
http://localhost:8080
and
http://127.0.0.1:8080

Please try and answer my questions exactly and with details as they are important steps to troubleshoot your issue...
...that is if you still want your issues looked at?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with windows server 2003 sp1

Postby sileng » 02. June 2009 05:30

when i use localhost:8080 or 127.0.0.1:8080 it says connection error. but when i try 192.168.1.73:8080 it doesn't load, all it say is waiting for 192.168.1.73...i appreciate you helping me out :D
sileng
 
Posts: 6
Joined: 02. June 2009 04:38

Re: Help with windows server 2003 sp1

Postby Sharley » 02. June 2009 05:37

Try disabling temporarily your firewall and then try the http://localhost:8080 again and at this point I am only interested in testing localhost and 127.0.0.1 not your IP, which may be a different issue.

Let us do one thing at a time.

Let me know back what happens when you disable your firewall and remember to frequently clear your browser's cache when working at local level.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with windows server 2003 sp1

Postby sileng » 02. June 2009 06:11

so this is what i get with http://localhost:8080

Image


that's the same result when i try http://127.0.0.1:8080...my firewall is disabled
sileng
 
Posts: 6
Joined: 02. June 2009 04:38

Re: Help with windows server 2003 sp1

Postby Sharley » 02. June 2009 06:27

What changes exactly did you make in the xampp\apache\conf\httpd.conf file?

Is apache and mysql running?

Check using xampp\xampp-control.exe and see if both Apache and MySQL have the green running indication.

EDIT
Make sure that the first line after all the commented entries in your C:\Windows\system32\drivers\etc\Hosts file looks like this:
127.0.0.1 localhost

and if you see this line:
::1 localhost
then comment it out like so:
# ::1 localhost
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with windows server 2003 sp1

Postby sileng » 02. June 2009 06:41

all i did was change listen 80 to listen 8080...everything is working apache and mysql, both are running with no problems...




# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost
sileng
 
Posts: 6
Joined: 02. June 2009 04:38

Re: Help with windows server 2003 sp1

Postby Sharley » 02. June 2009 06:55

Sometimes this helps:
Listen *:80

Instead of simply:
Listen 80



A bit further down in the httpd.conf file is this line:
ServerName localhost:80

Try either dropping the :80 or changing the line to:
ServerName localhost:8080

Save the file and don't forget to restart Apache every time you make edits so that the server can recognize the new edited configurations.

Make sure you clear/delete your browser's cache often in Firefox:
Options>Advanced>Networks>Cache>Clear Now
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests