Can't start Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't start Apache

Postby rocket » 31. May 2009 20:29

running Windows Vista Home Premium. Have UAC activated and Xampp in C:\\xampp.
However, i cannot start Apache and use Xampp.

Is it now possible to run Xampp in Vista?

Thanks
rocket
 
Posts: 5
Joined: 31. May 2009 20:25

Re: Can't start Apache

Postby rocket » 31. May 2009 20:32

Ok,

I unchecked the box (Svc) next to Apache, clicked OK to uninstall and then started apache, and presto, it now works.

Can anyone tell me what happened?

Cheers
rocket
 
Posts: 5
Joined: 31. May 2009 20:25

Re: Can't start Apache

Postby Morris.Lau » 02. June 2009 01:42

Hi Rocket please look here"Vista Note: Because missing or insufficient write permissions in the c:\program files folder of the default vista installation, we recommend to use alternate folders for XAMPP e.g. c:\xampp or c:\myfolder\xampp.
"or herehttp://www.apachefriends.org/en/xampp-windows.html
rocket wrote:running Windows Vista Home Premium. Have UAC activated and Xampp in C:\\xampp.
However, i cannot start Apache and use Xampp.

Is it now possible to run Xampp in Vista?

Thanks
User avatar
Morris.Lau
 
Posts: 3
Joined: 02. June 2009 01:20

Re: Can't start Apache

Postby Sharley » 02. June 2009 01:55

rocket wrote:running Windows Vista Home Premium. Have UAC activated and Xampp in C:\\xampp.
However, i cannot start Apache and use Xampp.

Is it now possible to run Xampp in Vista?

Thanks
To run any XAMPP service you need to disable UAC and be logged in as an Administrator.



@Morris.Lau

The OP is using C:\xampp and not C:\Program Files as pointed out above.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start Apache

Postby rocket » 02. June 2009 03:50

when i installed Xampp, i got a warning that said that having UAC disabled would cause restrictions in Xampp, so i enabled it.

What should i do?
rocket
 
Posts: 5
Joined: 31. May 2009 20:25

Re: Can't start Apache

Postby Sharley » 02. June 2009 04:18

rocket wrote:when i installed Xampp, i got a warning that said that having UAC disabled would cause restrictions in Xampp, so i enabled it.

What should i do?
Disable UAC if you want to run a web server like that included in XAMPP as the above warning is a hard coded system message and as we all know, Vista and Microsoft does not like you to have too much control of your PC.

Can you install XAMPP and is it working now?

If not provide some error messages or at least give us more details of what you have tried and what you see on your monitor, in other words relay to us as much detail as possible about your issues then we have a better chance of troubleshooting it for you.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start Apache

Postby rocket » 02. June 2009 04:58

Xampp is running fine now. I turned on uac before installing because of the restriction warning. No error messages.

If i disable UAC now, will it mess things up?

All i want to do is test sites locally, such as Joomla, etc. I think i should be ok. Just don't want to mess anything up by turning UAC off.
Had it turned off cause its a pain.

Thanks
rocket
 
Posts: 5
Joined: 31. May 2009 20:25

Re: Can't start Apache

Postby Sharley » 02. June 2009 05:05

Sharley wrote:Disable UAC if you want to run a web server like that included in XAMPP as the above warning is a hard coded system message and as we all know, Vista and Microsoft does not like you to have too much control of your PC.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start Apache

Postby Morris.Lau » 02. June 2009 07:15

VeryThanks Sharley
Sharley wrote:
Sharley wrote:Disable UAC if you want to run a web server like that included in XAMPP as the above warning is a hard coded system message and as we all know, Vista and Microsoft does not like you to have too much control of your PC.
User avatar
Morris.Lau
 
Posts: 3
Joined: 02. June 2009 01:20

Re: Can't start Apache

Postby Sharley » 02. June 2009 07:21

Also consider becoming a Vista Super Administrator:
http://www.winvistaclub.com/t12.html
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start Apache

Postby rocket » 02. June 2009 15:08

Thanks for all of your help. this forum is very helpful. I'm a web developer and not really as savvy as i would like to be on the tech end of things.

Thanks so much.
rocket
 
Posts: 5
Joined: 31. May 2009 20:25


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 67 guests