Connection Interrupted

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Connection Interrupted

Postby Serenitee » 31. May 2009 02:35

I have seen many with similar issues, here and posted elsewhere - but no solid "correction" (the ones I have tried did not work). Just recently installed xampp 1.7.1 to laptop (XP pro) and have been working with it for approximately a week on a website with no issues.

Suddenly today, when clicking submit on one of my forms, I receive the following error:
Connection Interrupted
The connection to the server was reset while the page was loading.
The network link was interrupted while negotiating a connection. Please try again.

I stopped and restarted apache/mysql.
stopped them again, rebooted laptop, then started them and attempted the page again.
Tried the same page in IE (typically use FF3) - same problem.

Assuming it was something in my code, I backed up to the current live version - same error. Checked it on live server - works fine. Checked on other computer running xampp 1.6.4 - no error, works as it should (that computer is XP home - running same browsers as on laptop).

I then started hitting google and tried many things (firewall off, no change - check ports, all looks fine, change php.ini to disable PDO, no change.

apache error log looks to be showing the issue is there:
Code: Select all
[Sat May 30 17:53:32 2009] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sat May 30 17:53:32 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 30 17:53:32 2009] [notice] Digest: done
[Sat May 30 17:53:33 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 configured -- resuming normal operations
[Sat May 30 17:53:33 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat May 30 17:53:33 2009] [notice] Parent: Created child process 5072
[Sat May 30 17:53:34 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 30 17:53:34 2009] [notice] Digest: done
[Sat May 30 17:53:35 2009] [notice] Child 5072: Child process is running
[Sat May 30 17:53:35 2009] [notice] Child 5072: Acquired the start mutex.
[Sat May 30 17:53:35 2009] [notice] Child 5072: Starting 250 worker threads.
[Sat May 30 17:53:35 2009] [notice] Child 5072: Starting thread to listen on port 443.
[Sat May 30 17:53:35 2009] [notice] Child 5072: Starting thread to listen on port 80.


I'm at a total loss here. I don't really "know" servers well, I just work with the webpages and dabble elsewhere. Any pointers, assistance, troubleshooting - heck even sympathy if unknown resolution by any viewing - appreciated.

tia!
Serenitee
 
Posts: 5
Joined: 31. May 2009 02:17

Re: Connection Interrupted

Postby Sharley » 31. May 2009 02:43

The error log is only showing information [notice]s not [error]s so it is assumed that Apache has started according to the last entries.

Can you access http://localhost/index.html

If not can you access via http://127.0.0.1/index.php and load the Welcome Page?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Connection Interrupted

Postby Serenitee » 31. May 2009 03:33

I can access via both, and can load the index.php page of my script - the error occurs when I submit the form and attempt to load the next page. Other php scripts are fine. This particular script has a form for information, submits, goes to page 2 where it accesses mysql looking for matches from a preg_match'd parse, returns information for confirmation, then will go to step3 - returning the final information.

So, what is going on when the error occurs would be
    a GET check to see what stage the form is in (original form, step2 to check db and return choices for the user to choose from, step3 returning the db information)
    Pulling post data into variables
    performing the preg_match_all statements placing data in arrays
    checking the database against the arrays
    creating sessions
    returning page 2 (a new form) with 3 columns of database information so the user can make the 'correct' choices from the listed options


My next step of course could be commenting out each 'step' to attempt to determine where the server is having an issue - but I find it odd it works fine both Live and on 1.6.4 with no problems.

tia
Serenitee
 
Posts: 5
Joined: 31. May 2009 02:17

Re: Connection Interrupted

Postby Serenitee » 31. May 2009 03:36

Error log since above error log, attempting to run form again.

Code: Select all
[Sat May 30 17:59:13 2009] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sat May 30 17:59:13 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 30 17:59:13 2009] [notice] Digest: done
[Sat May 30 17:59:14 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 configured -- resuming normal operations
[Sat May 30 17:59:14 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat May 30 17:59:14 2009] [notice] Parent: Created child process 692
[Sat May 30 17:59:15 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 30 17:59:15 2009] [notice] Digest: done
[Sat May 30 17:59:16 2009] [notice] Child 692: Child process is running
[Sat May 30 17:59:16 2009] [notice] Child 692: Acquired the start mutex.
[Sat May 30 17:59:16 2009] [notice] Child 692: Starting 250 worker threads.
[Sat May 30 17:59:16 2009] [notice] Child 692: Starting thread to listen on port 443.
[Sat May 30 17:59:16 2009] [notice] Child 692: Starting thread to listen on port 80.
[Sat May 30 19:31:00 2009] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Sat May 30 19:31:00 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 30 19:31:00 2009] [notice] Digest: done
[Sat May 30 19:31:01 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 configured -- resuming normal operations
[Sat May 30 19:31:01 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat May 30 19:31:01 2009] [notice] Parent: Created child process 5532
[Sat May 30 19:31:02 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 30 19:31:02 2009] [notice] Digest: done
[Sat May 30 19:31:03 2009] [notice] Child 5532: Child process is running
[Sat May 30 19:31:03 2009] [notice] Child 5532: Acquired the start mutex.
[Sat May 30 19:31:03 2009] [notice] Child 5532: Starting 250 worker threads.
[Sat May 30 19:31:03 2009] [notice] Child 5532: Starting thread to listen on port 443.
[Sat May 30 19:31:03 2009] [notice] Child 5532: Starting thread to listen on port 80.
Serenitee
 
Posts: 5
Joined: 31. May 2009 02:17

Re: Connection Interrupted

Postby Serenitee » 31. May 2009 04:40

Well, stepping through my script, seems to be a coding error in general, specifically:

preg_match_all("/\[(.+?)\] You begin work on (.+?)\.(\s+)(.+?\s+){0,2500}?\[(.+?)\] (You fail to make (.+?) (but lose no|and lose some) materials|You fail to make (.+?)|You successfully make (.+?)|You are no longer making (.+?)|You move and cancel the product you were making)(\.|!)/", $data, $greenbar);

So, will likely need a differing place to find the actual answer. I have many instances of preg_match_all in this portion of this script, commenting that one out - the script continues properly - commenting any/all of the others out it times out. More specifically, it is the {0,2500} within that preg match - seems it does not like such a large area to skip and it times out causing an interruption perhaps? Any know of any differences between 1.6.4 and 1.7.1 that perhaps would effect this?
Serenitee
 
Posts: 5
Joined: 31. May 2009 02:17

Re: Connection Interrupted

Postby Serenitee » 31. May 2009 09:19

Well, no fix, but found a work around by lowering the lines from 2500 in my preg_match_all statement to 250 (275 returned error, 250 works /shrug).

I'm sure there is a setting somewhere that has changed between v1.6.4 and v1.7.1 - but I haven't a clue where to even look.

So, semi-resolved - I'm able to continue working using my work around at least :)
Serenitee
 
Posts: 5
Joined: 31. May 2009 02:17

Re: Connection Interrupted

Postby foyleman » 02. August 2009 13:18

Same issue here, although I don't have the luxury of trimming the number of lines for a solution. I'm already under 250 lines... using the script on my .htaccess file.

To restate... preg_match_all causes the script to break and eventually displays a connection interruption error. Comment out the line and script runs fine. Use the same script on a server not running xampp and it works fine.
foyleman
 
Posts: 5
Joined: 23. March 2009 21:49


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests