phpnuke forum problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpnuke forum problem

Postby Drezek » 24. May 2009 01:30

okay i tired install nuke and activated the forum module but when i click on forums in the modules administation i get a http 500 error i tried installing it on another computer but i get the same problem one vista and the other xp it has to be something with xampp i dont know what to do it is getting very frustrating
Drezek
 
Posts: 8
Joined: 23. May 2009 10:25

Re: phpnuke forum problem

Postby Sharley » 24. May 2009 01:51

...it has to be something with xampp...
More likely to be something in PHP-Nuke or the Forum module (.htaccess file perhaps).

Server 500 errors should be investigated using the server's error log file:
xampp\apache\logs\error.log
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpnuke forum problem

Postby Drezek » 24. May 2009 03:08

Code: Select all
[Sat May 23 10:03:39 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat May 23 10:03:39 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 23 10:03:39 2009] [notice] Digest: done
[Sat May 23 10:03:41 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9 configured -- resuming normal operations
[Sat May 23 10:03:41 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat May 23 10:03:41 2009] [notice] Parent: Created child process 3716
[Sat May 23 10:03:42 2009] [notice] Digest: generating secret for digest authentication ...
[Sat May 23 10:03:42 2009] [notice] Digest: done
[Sat May 23 10:03:44 2009] [notice] Child 3716: Child process is running
[Sat May 23 10:03:44 2009] [notice] Child 3716: Acquired the start mutex.
[Sat May 23 10:03:44 2009] [notice] Child 3716: Starting 250 worker threads.
[Sat May 23 10:03:44 2009] [notice] Child 3716: Starting thread to listen on port 443.
[Sat May 23 10:03:44 2009] [notice] Child 3716: Starting thread to listen on port 80.
[Sat May 23 18:07:34 2009] [warn] (OS 64)The specified network name is no longer available.  : winnt_accept: Asynchronous AcceptEx failed.
[Sat May 23 18:23:38 2009] [error] [client 66.249.68.230] File does not exist: C:/xampp/htdocs/wsd/robots.txt
[Sat May 23 18:23:39 2009] [error] [client 66.249.68.230] File does not exist: C:/xampp/htdocs/wsd/tryaxyftpjcarsgl.html
[Sat May 23 18:39:03 2009] [error] [client 219.153.66.61] script 'C:/xampp/htdocs/proxyheader.php' not found or unable to stat
[Sat May 23 18:55:14 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/images/favicon.ico
[Sat May 23 18:59:57 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/includes/tiny_mce/langs/.js, referer: http://fallenangels.me/admin.php
[Sat May 23 19:00:13 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/includes/tiny_mce/langs/.js, referer: http://fallenangels.me/admin.php
[Sat May 23 19:00:19 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/includes/tiny_mce/langs/.js, referer: http://fallenangels.me/admin.php
[Sat May 23 19:15:06 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/htdocs/fa/admin
[Sat May 23 19:17:00 2009] [error] [client 192.168.1.1] File does not exist: C:/xampp/htdocs/fa/includes/tiny_mce/langs/.js, referer: http://www.fallenangels.me/
[Sat May 23 19:30:58 2009] [error] [client 192.168.1.1] File does not exist: C:/xampp/htdocs/fa/fourm
[Sat May 23 19:37:07 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/images/spacer.gif, referer: http://fallenangels.me/admin.php?op=Configure
[Sat May 23 19:37:20 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/images/spacer.gif, referer: http://fallenangels.me/admin.php?op=modules
[Sat May 23 19:37:29 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/images/spacer.gif, referer: http://fallenangels.me/admin.php?op=home_module&mid=7
[Sat May 23 19:40:02 2009] [error] [client 192.168.1.1] File does not exist: C:/xampp/htdocs/fa/images/spacer.gif, referer: http://www.fallenangels.me/
[Sat May 23 19:43:31 2009] [error] [client 192.168.1.1] File does not exist: C:/xampp/htdocs/fa/images/favicon.ico
[Sat May 23 19:59:53 2009] [error] [client 192.168.1.1] File does not exist: C:/xampp/htdocs/fa/adm
[Sat May 23 20:09:20 2009] [error] [client 65.55.246.77] File does not exist: C:/xampp/htdocs/wsd/robots.txt
[Sat May 23 20:28:23 2009] [error] [client 66.249.68.230] File does not exist: C:/xampp/htdocs/wsd/intro.html
[Sat May 23 21:26:35 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/themes/style, referer: http://www.fallenangels.me/
[Sat May 23 21:26:36 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/favicon.ico
[Sat May 23 21:30:22 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/themes/style, referer: http://127.0.0.1/fa/
[Sat May 23 21:36:20 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/fa/themes/style, referer: http://127.0.0.1/fa/
[Sat May 23 21:50:17 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/images
[Sat May 23 21:53:22 2009] [error] [client 66.249.68.230] File does not exist: C:/xampp/htdocs/wsd/freedns.afraid.org

here are thge latest errors i couldnt find anything having to do with my problem
Drezek
 
Posts: 8
Joined: 23. May 2009 10:25

Re: phpnuke forum problem

Postby Drezek » 24. May 2009 03:45

okay i gave up on phpnuke 8.0 so i installed 7.0 and now im having another problem i log in and i click on one of the items on the admin menu then it brings me back to the admin login
Drezek
 
Posts: 8
Joined: 23. May 2009 10:25

Re: phpnuke forum problem

Postby Drezek » 24. May 2009 03:55

Drezek
 
Posts: 8
Joined: 23. May 2009 10:25

Re: phpnuke forum problem

Postby Sharley » 24. May 2009 04:00

here are thge latest errors i couldnt find anything having to do with my problem

There is a process of elimination when you are looking for a particular error in a large error.log file like the one you posted.

You can eliminate all [notice] entries - not an error.
Also eliminate [warn] entries - not an error.
Eliminate all file not found or file does not exist [error] entries - they are 404 errors

What are we left with?

Only 1 entry and that is a 500 error.
when i click on forums in the modules administation i get a http 500 error
Code: Select all
[Sat May 23 19:15:06 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/htdocs/fa/admin

Can you see the link from the error message you posted in the above quote to the error log file entry?
C:/xampp/htdocs/fa/admin

Look in that folder for a .htaccess file and rename or move it out of the folder and see if you still get the error 500 message but remember to clear your browser's cache.

If you don't get the error 500 message after renaming or removing the .htaccess file then investigate the contents of the .htaccess file which would have been put in the above folder when you installed PHP-Nuke - you should investigate the .htaccess file no matter what the outcome is when you rename or remove it.



Your other issues posted after this reply refers to another version of PHP-Nuke and is not included in this reply.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 74 guests