Ports in use on install

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Ports in use on install

Postby tonyscarpelli » 21. May 2009 13:16

I'm somewhat new using Apache and PHP which I am learning, but I know mySQL a bit.

When I was installing XAMPP 1.7.1 I got a message:

"Ports 80 or 443 (SSL) already in use! Installing Apache2.2 service failed!"

Is this a real problem?

It seems on one of my computers I can't run my PHP scripts, but on one of my other computers I can start Apache and I can run the scripts.

Where can I fix this error? What can be done about this?

Thanks.
tonyscarpelli
 
Posts: 1
Joined: 21. May 2009 13:01

Re: Ports in use on install

Postby Sharley » 22. May 2009 00:07

tonyscarpelli wrote:"Ports 80 or 443 (SSL) already in use! Installing Apache2.2 service failed!"
Run xampp-portcheck.exe in the xampp installation folder and find out what is using those ports.

Usually Skype which you can reconfigure to use other ports.

Or Internet Information Service (IIS), the Windows server uses those ports by default and if so then you can disable IIS from the Windows Control Panel>Add/Remove Programs>Add/remove Windows Components or similar named links.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Ports in use on install

Postby denzel » 25. May 2009 22:51

I to am haveing a problem with port 80, when I do the port check the result is
port 80 - C:\WINDOWS\system32\inetsrv\inetinfo.exe can I do anything about this ?
denzel
 
Posts: 3
Joined: 26. October 2008 22:07

Re: Ports in use on install

Postby Sharley » 26. May 2009 00:26

denzel wrote:...port 80 - C:\WINDOWS\system32\inetsrv\inetinfo.exe can I do anything about this ?
This is IIS (intesrv\inetinfo - Internet Information Service) using port 80 and if you read my last post you can find what to do about it - the paths are relative to XP.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests