Page 1 of 1

can't access phpmyadmin

PostPosted: 20. May 2009 22:30
by ignas2526
I was using 1.6.8 version and today i installed new 1.7.1, after fresh install i was not able to access mysql via phpmyadmin, it keeps dropping me this error:
Code: Select all
MySQL said: 
Cannot connect: invalid settings.
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

here is code of from phpmyadmin:
Code: Select all
 * This is needed for cookie based authentication to encrypt password in
 * cookie
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

 * Servers configuration
$i = 0;

 * First server

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

 * End of servers configuration


I tried to reinstall XAMPP, tried to execute resetroot.bat still nothing.
Apache starts like in old version, but mysql_start.bat shows me every time this:
Code: Select all
Diese Eingabeforderung nicht waehrend des Running beenden
Please dont close Window while MySQL is running
MySQL is trying to start
Please wait  ...
MySQL is starting with mysql\bin\my.cnf (console)
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
090521  0:07:37  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
090521  0:07:37  InnoDB: Started; log sequence number 0 46409
090521  0:07:37 [Note] Event Scheduler: Loaded 0 events
090521  0:07:37 [Note] mysql\bin\mysqld: ready for connections.
Version: '5.1.33-community'  socket: ''  port: 3306  MySQL Community Server (GPL

This is Windows version of XAMPP, Windows XP.
Interesting thing is what i can view and edit CD Collection Demo in XAMPP which uses MySQL and same authentication settings as phpmyadmin...
Any ideas how to fix phpmyadmin?
Thanks for help.

Re: can't access phpmyadmin

PostPosted: 20. May 2009 22:52
by Sharley
Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'config';

Try changing this to:
Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'cookie';

Then enter root as the username and your password if you created one or leave the password field blank if you don't have one and see if that allows access.

Re: can't access phpmyadmin

PostPosted: 20. May 2009 23:43
by ignas2526
still getting same message...

Re: can't access phpmyadmin

PostPosted: 21. May 2009 00:28
by Sharley
Revert that entry to config and enter your password for root in the space provided.

Clear you browser's cache (delete Temporary Internet Files in IE).

Try again to access using root and your password in the phpMyAdmin login screen.

Re: can't access phpmyadmin

PostPosted: 21. May 2009 11:11
by ignas2526
Dude forgot about that damn feature in IE...
yes, after setting $cfg['Servers'][$i]['auth_type'] = 'cookie'; and deleting cache it finally works!
Thank you very much.