Page 1 of 1

virtual host domain with www not accessible!

PostPosted: 20. May 2009 18:10
by agony
Hi ! i have been searching the forum and google for any similar issues but haven't found any answers, so i guess you are my last hope!

My problem is that my domain is not accessible when one enters http://www.domain.com in the browser. Just domain.com works perfect but
http://www.domain.com just won't work from external source, nothing happens! but it works locally but i really need users to be able enter http://www.domain.com ofcourse! :x

Here is my vhosts.conf :

Code: Select all
<VirtualHost *:80>
ServerName localhost
DocumentRoot "c:/xampp/htdocs"
</VirtualHost>

<VirtualHost *:80>
ServerName www.domain.com
ServerAlias domain.com
DocumentRoot "c:/xampp/htdocs/domain"
</VirtualHost>

<VirtualHost *:80>
ServerName domain2.dyndns.org
DocumentRoot "c:/xampp/htdocs/domain2"
</VirtualHost>


The domain.com vhost is the one with issues! Have anyone got a clue ?
I have tried adding and replacing virtual hosts now too many times, i just can't get it to work!
Also have added http://www.domain.com and domain.com in my windows host's file, still same issue.

So please someone , help ! why isn't http://www.domain.com working ?

Re: virtual host domain with www not accessible!

PostPosted: 20. May 2009 18:15
by Wiedmann
http://www.domain.com just won't work, nothing happens!

Not even an error message?

Re: virtual host domain with www not accessible!

PostPosted: 20. May 2009 20:38
by agony
No nothing :( browser just says connecting... and nothing happens!