[solved] Problem with Curl and php.ini

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[solved] Problem with Curl and php.ini

Postby guischarf » 15. May 2009 20:04

Hello,

I am running XAMPP 1.7.1 (installer version) in Win XP SP3. When uncommenting (removing the ';') extension=php_curl.dll in \xampp\php\php.ini, apache will not start. No errors about this are logged in \xampp\apache\logs\error.log. Commenting the curl extension again fixes the problem.

php.ini is no longer in \xampp\apache\bin, as is used to be. Wondering if the problem has some relation to this fact.

Anybody knows how to fix this?

Thanks
Last edited by guischarf on 15. May 2009 22:22, edited 1 time in total.
guischarf
 
Posts: 11
Joined: 10. January 2008 21:54

Re: Problem with Curl and php.ini

Postby guischarf » 15. May 2009 20:32

I fixed it. The problem was that Curl requires that these two files: libeay32.dll and ssleay32.dll, found in xampp\php, be copied to winn\system or winn\system32 (documentation in php manual is not very clear, so I copied to both) or be present in you path. This is from php.net/curl

Note: Note to Win32 Users
In order to enable this module on a Windows environment, libeay32.dll and ssleay32.dll must be present in your PATH. You don't need libcurl.dll from the cURL site.
guischarf
 
Posts: 11
Joined: 10. January 2008 21:54


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests