Xampp not loading Properly in GChrome or Firefix

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp not loading Properly in GChrome or Firefix

Postby tuai » 05. May 2009 17:35

Hello all gurus of AF,

Am very new here, a newbie to xampp, actually.

My problem:
1. I have installed xampp on my vista (in my c/: drive, which is "c:/xampp")
2. When I launch xampp c/panel, all (apache, mysql & mecury) are running except filezilla (indicated by the green highlights).
3. When i launch either one of my browsers, and type "http://localhost/xampp" the "Xampp furfor Windows" do come up. But when I tried to click the "Security" link, or even some other links on that page, I always receive the error message: Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.
If you think this is a server error, please contact the webmaster.
Error 403
127.0.0.1
05/06/09 00:24:49
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8


This is frustrating to me. I cannot go any further. I have even tried to type other ".php" files, they did not work either.
(I have checked, and re-checked all the xampp folder contents, and all the ".php" files have dreamweaver icons on them. The xampp folder content is similar to those mentioned in AF tutorials, etc...)

Please tell me what to do next. Thank you in advance.
tuai
 
Posts: 1
Joined: 05. May 2009 17:07

Re: Xampp not loading Properly in GChrome or Firefix

Postby Sharley » 06. May 2009 00:58

But when I tried to click the "Security" link, or even some other links on that page, I always receive the error message: Access forbidden!
An advanced forum search in the XAMPP for Windows forum for Access forbidden (link) may have given you the answer quicker than waiting for a reply and being a new forum member doesn't excuse you from first reading the forum Announcements (link) before making your first post. ;)
Our forum search facility will most often contain the answers you are looking for as most questions have already been asked.

BTW if you read in some of the search result replies above that you need to change only one line of code then this is incorrect - look for a reply that specifically mentions to change 2 lines of code.

Please post back if you find the solution in the search result replies that will now allow access to the security page - Thanks.

The DreamWeaver icon issue means that you have set DW to open php files by default when you double click on a php file for editing - I have mine set to open in my text editor and so php files show the associated text editor icon.
This will have no effect on when a php file is accessed from a URI in your browser like http://localhost/index.php so the server can parse the php code.

If as you say you can access http://localhost/ and run the demos then your installation using versions prior to the latest 1.7.1 and after you fix the security page issue, will be fine.
The latest version 1.7.1 has most of the bugs in prior versions, including the security page issue you mention above, fixed.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests