router config page problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

router config page problem

Postby James-2009 » 04. May 2009 19:28

Hi,

I'm using a D-Link wireless router. I installed xampp and after running Apache, when i go to the web browser and type : localhost everything is working fine. all the files are listed inside htdocs folder.

the problem is i need to place some personal files within htdocs and send a link to my friend to download that content. but obviously i cant give him a like like : http://localhost/myfiles/etc...

so when i tried using my IP address, it straight away goes to router config page. how can i make my IP points to htdocs? so i can give a direct download link to my friend

Edit : I'm using Vista

any help?
James-2009
 
Posts: 2
Joined: 04. May 2009 19:19

Re: router config page problem

Postby make-fun » 06. May 2009 08:06

Hi there

You need to look into Portforwarding, but really read about it, so you know what you are doing!
You'll open this to the whole internet!

Cheers
make-fun
 
Posts: 31
Joined: 11. March 2009 04:21

Re: router config page problem

Postby James-2009 » 06. May 2009 13:27

i opened the port 80 for http. but still no luck :(
James-2009
 
Posts: 2
Joined: 04. May 2009 19:19

Re: router config page problem

Postby make-fun » 06. May 2009 23:54

Well first of all — I really urge you to read and understand what "PortForwarding" does and why it's a huge risk for your network and the whole wide Internet!
For now, you opened port 80 on your router, but xampp is on a computer — think about it, this is a missmatch. This is where the word "Forwarding" comes into play…

Cheers
make-fun
 
Posts: 31
Joined: 11. March 2009 04:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests