Missing php.ini

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Missing php.ini

Postby Sheza » 02. May 2009 17:33

Hi there.

I installed XAMPP via the Windows exe. I navigate to my xampp/apache/bin folder and look for php.ini, it's not there!

I need this file to enable ZEND Optimizer. Why is it not in there?
Sheza
 
Posts: 3
Joined: 02. May 2009 17:31

Re: Missing php.ini

Postby Wiedmann » 02. May 2009 17:53

Ask "phpinfo()" which "php.ini" is used.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Missing php.ini

Postby Sheza » 02. May 2009 17:58

Loaded Configuration File C:\xampp\php\php.ini


I actually edited that file. I need to use Zend Optimizer, it says
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies


However when I go to install.php it says Zend Optimizer is not installed.

I have edited as it says so.
[Zend]
zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:


Is there something I am doing wrong?

EDIT: I got it working! Thanks for your help!
Last edited by Sheza on 02. May 2009 18:03, edited 1 time in total.
Sheza
 
Posts: 3
Joined: 02. May 2009 17:31

Re: Missing php.ini

Postby Wiedmann » 02. May 2009 18:02

However when I go to install.php it says Zend Optimizer is not installed.

I guess that's a wrong message from your installer.
--> Your installer want have also the "Zend Loader" enabled. And not only the Optimizer.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Missing php.ini

Postby Sheza » 02. May 2009 18:03

It turned out I still had it set to 0 instead of 1, I swear I edited it but.. ah well, it works now!
Sheza
 
Posts: 3
Joined: 02. May 2009 17:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 79 guests