Xampp - Apache listen port keeps switching back to port 80

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp - Apache listen port keeps switching back to port 80

Postby entropicsinkhole » 30. April 2009 18:02

Xampp v. 1.7.1

Apache - Frequently (but not always) when I restart the Apache service, the port will switch back to port 80 (in the config file I changed it to 1066), with the message of 'Apache starte [Port 80] in the Xampp control panel. At this time, it acts as if the service has not started at all (there is only a 'Start' button beside Apache service in the Xampp control panel). I have to stop the service via Admin Tools > Services and then restart it from the Xampp control panel. Why is it doing that and how can I stop it?
entropicsinkhole
 
Posts: 6
Joined: 31. May 2007 16:37

Re: Xampp - Apache listen port keeps switching back to port 80

Postby Sharley » 30. April 2009 23:23

entropicsinkhole wrote:...the port will switch back to port 80 (in the config file I changed it to 1066), with the message of 'Apache starte [Port 80] in the Xampp control panel.
You can ignore this message in the XAMPP Control Panel as it is hard coded to port 80 - http://localhost:1066 should be the URI now and you would have to add the port number to all requests in your browser from now on.

entropicsinkhole wrote:At this time, it acts as if the service has not started at all (there is only a 'Start' button beside Apache service in the Xampp control panel). I have to stop the service via Admin Tools > Services and then restart it from the Xampp control panel. Why is it doing that and how can I stop it?
If it happens again try starting it with apache_start.bat file and read the message why it can't start.

Unless you specifically need Apache starting after every reboot then there is no need to install the service - try using the xampp\apache\apache_uninstallservice.bat file and the apache_installservice.bat file.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp - Apache listen port keeps switching back to port 80

Postby entropicsinkhole » 01. May 2009 12:06

Thanks! I use Apache with my webmail (squirrelmail) and need to restart the service whenever I make changes to the php.ini file. If it doesn't restart, it doesn't work. I'll check out the .bat file next time and see if it throws up an error!
entropicsinkhole
 
Posts: 6
Joined: 31. May 2007 16:37

Re: Xampp - Apache listen port keeps switching back to port 80

Postby Sharley » 02. May 2009 00:45

entropicsinkhole wrote:Thanks! I use Apache with my webmail (squirrelmail) and need to restart the service whenever I make changes to the php.ini file.
No need to restart the service only the Apache server either by clicking on the Apache Stop then on the Start buttons in the XAMPP Control Panel or by executing xampp_restart.exe in the xampp folder or by running the apache_stop.bat file and then the apache_start.bat file, all in the xampp installation folder - the above is in order of preference.

Running as a Windows service means that the app will be started by the system when ever you reboot your PC and so there is a registry entry created by Windows so it knows to do this procedure.

Starting and stopping an app like Apache manually has nothing to do with a Windows service so can be done at any time without there being a registry entry involvement but by using any of the above mentioned methods above.

I hope this helps a little.

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests