Enabling APC cache crashes apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Enabling APC cache crashes apache

Postby d7a7z7e7d » 29. April 2009 01:10

I've just downloaded XAMPP 1.7.1 zip package.

After getting everything configured, I went to enable APC by uncommenting the "#extension=php_apc.dll" line in php.ini. After restarting apache I hit phpinfo() and I see that apc is loaded successfully. However, if I refresh the page apache will crash. Basically after restarting apache with APC enabled I get one visit to a particular page before apache crashes. As soon as I disable APC apache works again.

I'm running Vista x64. Anyone else have this problem or have any ideas?

Thanks!
d7a7z7e7d
 
Posts: 1
Joined: 29. April 2009 01:06

Re: Enabling APC cache crashes apache

Postby dannyn » 15. May 2009 05:26

Exactly the same issue but I am running XP Pro.
Any help would greatly be appreciated...
dannyn
 
Posts: 1
Joined: 15. May 2009 05:17

Re: Enabling APC cache crashes apache

Postby DavidPesta » 05. June 2009 01:36

This stumped me a year ago, but today I have found the answer on a blog:

Disable everything related to zend in the php.ini. It comes in conflict with apc and you shouldn't need zend optimizer if you are wanting apc anyway.

I am a very happy David today. :mrgreen:
DavidPesta
 
Posts: 1
Joined: 05. June 2009 01:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests