Apache doesn't start on XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache doesn't start on XAMPP

Postby sandeep1026 » 28. April 2009 16:26

Hi,
I'm using windows Vista and Apache was working fine few weeks back. Suddenly when i started apache yesterday through XAMP control panel it didnt start.
it said
"Busy
Apache Started [80]"

So i suspected that it was problem with the port. I checked out and made sure that port 80 wasn't occupied. However i went to c:/xamp/apache/conf and opened apache.conf file and changed the port to 8080, 6060, 8075 etc... but still i couldn't start.

I checked out the error log but it is blank.

I repeated the above procedure by uninstalling and installing entire xamp but no luck. I don't have apache installed else where in the system.

However MySQL starts well. Can you please help me understand the problem and solve it
sandeep1026
 
Posts: 1
Joined: 28. April 2009 16:16

Re: Apache doesn't start on XAMPP

Postby Wiedmann » 28. April 2009 16:46

Start Apache with the batchfile and read the error message (if any).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache doesn't start on XAMPP--I have the same problem

Postby leoherder » 28. April 2009 19:46

I am a real newbie here but I'm having the same problem, sort of.

I can not get Apache to keeping running. After I click "start" I'm getting the same message

"Busy...
Apache started"

Then the "running" notice in the Modules. After about 5 seconds it stops running and just goes away..... Why????

It was working this morning, and, yes, I made a change to the Apache "httpd.conf" file. The change I made was inserting the following:

NameVirtualHost 127.0.0.1:80

<VirtualHost 127.0/0.1:80>
DocumentRoot "C:/program files/xampp/htdocs"
ServerName localhost
</VirtualHost>


<VirtualHost 127.0.0.1:80>
DocumentRoot C:/seophp/
ServerName seophp.example.com
<Directory C:/seophp/>
Options Indexes FollwSymLinks
AllowOverride All
Order allow, deny
Allow from all
</Directory>
</VirtualHost>

Why is making this change keeping it from running correctly? (I just commented out the change and Apache is running now.)

But what I'm trying to do is follow directions in a book to create a virtual host to handle examples. So I want my requests to
http://seophp.example.com/ to be served from a new folder, seophp. That is what the about change was for. But it is not working.

Wow. This is way too long maybe. But can anyone out there tell me what's going on?
leoherder
 
Posts: 3
Joined: 28. April 2009 19:11

Re: Apache doesn't start on XAMPP

Postby Wiedmann » 28. April 2009 19:50

I have the same problem

And I have the same answer. Read my last post.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache doesn't start on XAMPP

Postby leoherder » 29. April 2009 02:21

Thank you for your helpful reply. I had read your post and tried it and it did not work, which is why I posted the additional question. Any other ideas? There was no error message.
leoherder
 
Posts: 3
Joined: 28. April 2009 19:11

Re: Apache doesn't start on XAMPP

Postby Sharley » 29. April 2009 02:52

@leoherder
Wiedmann was being very helpful in the style that he knows best - it is normal practice to try and start Apache (or MySQL) using the apache_start.bat file (or mysql_start.bat file) if either fail to start in the normal manner as it will usually return a message explaining why they can't start.

Perhaps you could paste here the message in the console window after running the apache_start.bat file using the Edit menu found after clicking on the small icon top left in the console window.



BTW it looks like you have an issue with your virtual host entry and I believe you have been given some wrong instructions in the book you are reading.

Virtual host settings are placed in the file xampp\apache\conf\extra\httpd-vhosts.conf file not in the httpd.conf file - so I would delete the entries you made in the httpd.conf file and then use the httpd-vhosts.conf file.


NameVirtualHost 127.0.0.1:80 - should be:
NameVirtualHost *:80

<VirtualHost 127.0/0.1:80> - should be:
<VirtualHost *:80>

This should be:
<VirtualHost *:80>
DocumentRoot "C:/seophp"
ServerName seophp.example.com
<Directory "C:/seophp">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow, deny
Allow from all
</Directory>
</VirtualHost>


Always save the file after editing and restart Apache to have the edits recognized.

You also have to create an entry in C:\Windows\system32\drivers\etc\Hosts file:
127.0.0.1 seophp.example.com
Save the file after editing and try your URI http://seopphp.example.com in your browser again after making sure that Apache has started and remains running.


It is also helpful for troubleshooting if you include your XAMPP version and OS.


Another issue I spotted is you have installed XAMPP to a folder with a space in the name (Program Files) which may give you more issues down the track.

Always install to the root of a drive or partition like C:\ then XAMPP will be installed in C:\xampp which is the default and will always work down the track.


Please let us know back if the above helped in any way.
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache doesn't start on XAMPP

Postby Wiedmann » 29. April 2009 06:51

I had read your post and tried it and it did not work, which is why I posted the additional question. ... There was no error message.

So Apache should work.
a) Can you verify this with the Windows task manager?
b) Can you access Apache if you start it with the batchfile?
(how did you access apache? what can you read in your browser?)

I checked out the error log but it is blank.

There should be always something in the "error.log". Sure it's the correct one?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Apache doesn't start on XAMPP

Postby leoherder » 01. May 2009 20:25

Thank you everyone for your advice. I got it to work by uninstalling xampp and installing Apache separately. I've got my server up now. Thanks again.

leoherder
leoherder
 
Posts: 3
Joined: 28. April 2009 19:11

Re: Apache doesn't start on XAMPP

Postby elias75 » 06. May 2009 16:38

Hello,
I got a similar problem, Apache was running fine for 3-4 months since I installed it, but today, i started apache through XAMPP control panel and it didn't start.
it said
"Busy
Apache Started [80]" (MySQL was running fine - with the green "running" on)
then I restarted the Xampp CP and Mysql gave this error: "mysql service not started [-1]

here is a screen shot of my xampp CP now: http://img7.imageshack.us/img7/9141/xamppproblemy.jpg

please help! how do I correct this?

I am on XP (home) SP3 XAMPP (Basispaket) version 1.7.0

also if I type http://localhost/ on my browser I only get a plain white screen.

if I run apache_start.bat I get the following messages:

make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down, unable to open logs
Apache could not be started

please keep in mind that I am a newbie :roll:
elias75
 
Posts: 15
Joined: 12. March 2009 12:24

Re: Apache doesn't start on XAMPP

Postby Sharley » 06. May 2009 16:47

Sounds like you may have had an automatic upgrade from Microsoft that may have upset the apple cart.

make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down, unable to open logs
Apache could not be started
Run xampp-portcheck.exe in the xampp folder and find out what is using the port as it would seem you may have something else using the port that Apache needs - Skype perhaps?


For the MySQL issue run the xampp\mysql\mysql_installservice.bat file and see if that starts mysql by checking in the XAMPP Control Panel.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache doesn't start on XAMPP

Postby elias75 » 06. May 2009 17:01

yes it was skype! I disconnect and now Apache is running ok now but I still have the
"mysql service not running [-1] ??
elias75
 
Posts: 15
Joined: 12. March 2009 12:24

Re: Apache doesn't start on XAMPP

Postby Sharley » 06. May 2009 17:08

You can change the port that Skype uses in the Skype configuration so you can use Skype and Apache.

Go to start in the task bar and click on Run...
Type sc delete mysql
Click OK

Next run the mysql\mysql_installservice.bat file again and check with XCP that mysql has started.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache doesn't start on XAMPP

Postby elias75 » 06. May 2009 17:14

ok runs like a charm!!!!!!
many many many thanx for your help!! much appreciated! :D
elias75
 
Posts: 15
Joined: 12. March 2009 12:24


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests