BUSY warning #2 - Error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

BUSY warning #2 - Error

Postby julianjst » 28. April 2009 07:42

Hey. For some reason in the privledges I tried to add a password in two places, the two bottom quadrants of the user edit .

When I try to START Mysql in Xampp, it says:

Busy....
Mysql started [Port 3306]


In addition. When I run mysql_start.bat this comes up:

Please wait ...
MySQL is starting with mysql\bin\my.cnf <console>
mysql\bin\mysqld: Can't find file: 'plugin' <errno: 2>
090428 2:15:35 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090428 2:15:36 InnoDB: Started; log sequence number 0 46409
090428 2:15:36 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' <errno: 2>

MySQL konnte nicht gestartet weden
MySQL could not be started
Press any key to continue . . .


Any ideas. I would be very thankful.
Thank you
julianjst
 
Posts: 5
Joined: 28. April 2009 07:26

Re: BUSY warning #2 - Error

Postby Sharley » 28. April 2009 12:11

julianjst wrote:Hey. For some reason in the privledges I tried to add a password in two places, the two bottom quadrants of the user edit .
Can you please explain what you are trying to do here as it is not very clear - are you talking about creating a database in phpMyAdmin?

Did you read the Security section in the readme_en.txt file?

julianjst wrote:When I try to START Mysql in Xampp, it says:

Busy....
Mysql started [Port 3306]
Make sure that your firewall is not blocking port 3306 - open it if it is.


julianjst wrote:In addition. When I run mysql_start.bat this comes up:

Please wait ...
MySQL is starting with mysql\bin\my.cnf <console>
mysql\bin\mysqld: Can't find file: 'plugin' <errno: 2>
090428 2:15:35 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090428 2:15:36 InnoDB: Started; log sequence number 0 46409
090428 2:15:36 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' <errno: 2>

MySQL konnte nicht gestartet weden
MySQL could not be started
Press any key to continue . . .
What version of XAMPP are you using and what version of Windows?

Did you upgrade an older version of XAMPP or is it a new installation?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: BUSY warning #2 - Error

Postby julianjst » 28. April 2009 18:55

First off, I just installed xampp from the xampp website. It's new. I'm using Window XP.

Second, mysql is an exception on my windows firewall, so it's letting it pass.


When i first installed xampp, i could run mysql and access phpmyadmin no problem. But it said to make a password. So i Did, but at two different

places. Under priveleges, there were two places to put passwords, (one was info/panel, and before that block another one). So i plug in 4 passwords,

(2 twice, cuz they ask you to right it twice.)
julianjst
 
Posts: 5
Joined: 28. April 2009 07:26

Re: BUSY warning #2 - Error

Postby Sharley » 29. April 2009 00:47

The correct place to add a password for the super user root for MySQL/phpMyAdmin is mentioned in the Security section of the readme_en.txt file.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: BUSY warning #2 - Error

Postby julianjst » 29. April 2009 01:50

I tried doing that, it isn't working. Is there a way to reset everything ?
julianjst
 
Posts: 5
Joined: 28. April 2009 07:26

Re: BUSY warning #2 - Error

Postby Sharley » 29. April 2009 02:01

Run xampp\mysql\resetroot.bat file then follow the instructions in the readme file again and let me know back if it worked please.
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: BUSY warning #2 - Error

Postby julianjst » 29. April 2009 14:43

K. I ran it.

When i start Xampp, in the control panel, nothing changed. When I start mysql it goes green for 1 second, then stops.

but there's something different now, when i click on ADMIN really fast before start stops, FIREFOX pops up and asks for my username/password. when i insert root/pass, it says:

PHP ADMIN
ERROR#2003 - The server is not responding
julianjst
 
Posts: 5
Joined: 28. April 2009 07:26

Re: BUSY warning #2 - Error

Postby julianjst » 11. May 2009 01:01

i just delete every single file, php and other, that was in joomla or xampp folder. re-installed everything. its ok now.
julianjst
 
Posts: 5
Joined: 28. April 2009 07:26


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests