Page 1 of 1

not serving every page (some work, some blank, some weird)

PostPosted: 01. December 2003 15:11
by Tjark
I installed wampp 1.2 on W2K SP4 and got vhosts working. But some pages don't work as expected. I used IIS before so I know the websites are working (right paths etc).

e.g. The page is served, but the image isn't shown?
When you click on it to go to the next page (my girlfriends) then that page is ok. but when you go on to e.g. 'Thailand' it only shows a white page.

-- solved this one below: index file appeared to be in unicode. No problem for IIS, but Apache screws up ---
Another example: The site doesn't contain anything: just a black page with a simple flash animation. But when you browse to it it shows the html code, prefixed with "ÿþ" ???
I tried dos->unix conversion and vice versa, but that doesn't change it.

To make things even weirder: the phpmyadmin alias works perfectly and phpmyadmin is shown (with images etc) (secured by login)

It seems like there is something wrong with the rights or with the mime settings, but I didn't change the from the original installation.

btw: I changed the documentroot from "xampp/htdocs" to "www" in httpd.conf

Does anyone have a clue?

PostPosted: 02. December 2003 09:44
by Tjark
't seems there's something very weird going on.

when I try to 'wget' a file like 1000k (1mb testfile ) then I get results like:

Code: Select all
           => `1000k.2'
Connecting to connected!
HTTP request sent, awaiting response...
Read error (No such file or directory) in headers.

  (try: 2) => `1000k.2'
Connecting to connected!
HTTP request sent, awaiting response... 200 OK
Length: 1,000,000 [text/plain]

    0K .                                                       0% @   1.03 MB/s

09:43:54 (1.03 MB/s) - Read error at byte 1079/1000000 (No such file or director
y). Retrying.

  (try: 3) => `1000k.2'
Connecting to connected!
HTTP request sent, awaiting response... 206 Partial Content
Length: 1,000,000 (998,921 to go) [text/plain]

    0K ,.                                                      0% @1000.98 KB/s

09:43:54 (1000.98 KB/s) - Read error at byte 2104/1000000 (No such file or direc
tory). Retrying.

  (try: 4) => `1000k.2'
Connecting to connected!
HTTP request sent, awaiting response... 206 Partial Content
Length: 1,000,000 (997,896 to go) [text/plain]

    0K ,,.                                                     0% @1000.98 KB/s

I also get the same thing when getting a picture or other file.

when you try to 'save as' the above link, IE says 'the connection with the server was reset' :(

Butbutbutbut... when the 1000k file is in the https directory (still the original xampp/htdocs ), the download is ok (try to 'save as' the file):

Has onyone seen this before?

PostPosted: 02. December 2003 10:21
by Tjark
btw: when I go to (secure) i'm still directed to the original xampp htdocs dir. There everything seems to work (php tests, perl, mysqladmin etc).

So I believe I'm missing some setting when I changed my document dir from /xampp/htdocs to /www

PostPosted: 02. December 2003 23:34
by Tjark
and I continue my quest in finding what's wrong.

Here the access log of
Code: Select all - - [02/Dec/2003:23:37:06 +0100] "GET / HTTP/1.1" 304 - - - [02/Dec/2003:23:37:06 +0100] "GET /titeldechering.gif HTTP/1.1" 206 13969 - - [02/Dec/2003:23:37:06 +0100] "GET /transparent.gif HTTP/1.1" 304 - - - [02/Dec/2003:23:37:42 +0100] "GET / HTTP/1.1" 304 - - - [02/Dec/2003:23:37:42 +0100] "GET /titeldechering.gif HTTP/1.1" 206 15638 - - [02/Dec/2003:23:37:42 +0100] "GET /transparent.gif HTTP/1.1" 304 - - - [02/Dec/2003:23:37:55 +0100] "GET / HTTP/1.1" 304 - - - [02/Dec/2003:23:37:55 +0100] "GET /titeldechering.gif TTP/1.1" 206 11663 - - [02/Dec/2003:23:37:55 +0100] "GET /transparent.gif HTTP/1.1" 304 -

Notice the different size of 'titeldechering.gif' (13969, 15638 and 11663).

PostPosted: 03. December 2003 13:04
by Tjark
well, I did a complete reinstall, put 1000k in the standard htdocs dir and the problem is the same gives troubles works fine


PostPosted: 04. December 2003 11:22
by Tjark
I also tried minixampp and still the same problem. Tried another port (8080) to listen on: same problem.

but I guess this forum is no good. No reactions, no support... :cry:

PostPosted: 04. December 2003 12:45
by Tjark
I'm not giving up!

this happens when I try to wget the 1000k file. Every time wget tries to get another 'chunck' a log entry is made (I set Apache loglevel to debug)

Code: Select all
[Thu Dec 04 12:14:22 2003] [info] (OS 996)Overlapped I/O event is not in a signaled state.  : core_output_filter: writing data to the network
[Thu Dec 04 12:14:23 2003] [info] (OS 996)Overlapped I/O event is not in a signaled state.  : core_output_filter: writing data to the network
[Thu Dec 04 12:14:25 2003] [info] (OS 996)Overlapped I/O event is not in a signaled state.  : core_output_filter: writing data to the network

I also tried to change the MTU size of the network card (to 1452). It seems to have some influence: instead of chunks of around 2500 (first one is 2574 bytes and all following are 2520 bytes), I now receive chunks of 2482 and 2428 bytes.

In a usenet thread, someone is pointing to a driver misimplementation ( ). Especially because there is no problem when I'm accessing the site on the server itself (not from another computer). But it is also pointed out that the original poster didn't have a problem when he was using apache 1.3 before he was trying to get 2.0 to work.

My next guess is to change network cards and see if that works, but I try that when I'm at home again.

grrrrrrr. :evil:

https config

PostPosted: 04. December 2003 19:45
by MAGnUm
there is a config file for the default https server that is seperate from the httpd.conf. also if the default page that comes with wampp works correctly then there is something wrong with what you are trying to serve. if you want everything to work you should use plain text files only w/ no odd formatting. good luck.

PostPosted: 30. December 2003 14:50
by Tjark
well thanks for the tip, but that wasn't the problem.

I've solved it now. Well actually, I didn't solve it, I just reinstalled W2K again from scratch and now xampp worked right out of the box (with the same settings I had before).

So it looks like windows f*cked up someting, or it was a driver issue.
Anyway, if you experience the same awkward behaviour as I had, reinstall the os.
sad but true (but hey: it works now! :) )

PostPosted: 21. January 2004 12:23
by Tjark
time for an update :lol:

the server acted strange again. But this time if found out why. The night before I installed NOD32 antivirus....
Server showed the same strange things as before.
Shut down the antivirus: problem still the same.
De-installed the antivirus: problem was gone.

Should have thought of it earlier :oops:

A sollution is given in the FAQ of NOD32:

My Apache server does not work properly after installing NOD32 v2. Some pages do not load at all, some have missing pictures. What to do?

Apache web server uses sockets in a non-standard way and this results into conflicts with NOD32's IMON component. To resolve this issue, you need to recompile Apache's libapr.dll library with WAIT_FOR_EVENT preprocessor definition defined.

NOD32 v2?

PostPosted: 30. January 2004 16:14
by mkormendy
I'm curious about NOD32 v2, in your opinion why are you using it?
Please don't send me a link to their site, I've checked it out, but I would like a personal opinion, as it's quite intriging.
Thank you.

PostPosted: 18. May 2007 17:11
by yankee
I'm suffering a very similar problem that seems to relate to the same problem.

Did you recompile the DLL? Can you send it to me?


Forget about it... Easy solution:
2) go to IMON - Configuration - Other (last tab) - Exceptions and add apache's exe, restart computer...

Actually it's enough to restart Apache...
I did not test it, but perhaps even that is not necessary.