Busy Warnings

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Busy Warnings

Postby rparsons » 26. April 2009 23:33

I installed XAMP successfully and it was running fine.

Messing around with it I set wrong passwords for root and localhost and I couldn't access anything after that.

I deleted the XAMPP folder and reunzipped but when I try to start MySQL and Apache I get busy warnings

Any idea what to do?
rparsons
 
Posts: 7
Joined: 26. April 2009 23:27

Re: Busy Warnings

Postby Sharley » 26. April 2009 23:41

Did you install Apache and MySQL as a service in your first installation?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Busy Warnings

Postby rparsons » 26. April 2009 23:43

No. The installer wouldn't work. I had to unzip it. It worked the first time but not now. I am running XP
rparsons
 
Posts: 7
Joined: 26. April 2009 23:27

Re: Busy Warnings

Postby Sharley » 26. April 2009 23:51

You indicate that you tried first with the installer but it did not work which may have installed the services before you gave up on the attempt.

To remove these from the registry, if indeed they were created by the installer, follow these instructions that will do no harm and may just fix your issue.

Go to start>Run...
Type
sc delete apache2.2
Click OK

Then type
sc delete mysql
Click OK

Now try again to start Apache and MySQL.

Kindly let us know back if this fix worked for you.
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Busy Warnings

Postby rparsons » 26. April 2009 23:55

Unfortuneately no.

I still am getting the:
Busy....
Apache started [port 80]
Busy....
MySql started [Port 3306]
rparsons
 
Posts: 7
Joined: 26. April 2009 23:27

Re: Busy Warnings

Postby Sharley » 27. April 2009 00:00

rparsons wrote:Unfortuneately no.

I still am getting the:
Busy....
Apache started [port 80]
Busy....
MySql started [Port 3306]
That is what is supposed to happen and is telling you that they are both started.

Does the green running indication show in the XAMPP Control Panel next to Apache and MySQL?

What do you see when yo go to http://localhost in your browser?

Any clues in the xampp\apache\logs\error.log file?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Busy Warnings

Postby rparsons » 27. April 2009 00:07

No green light on either of them.

I get nothing with localhost or 127.0.0.1 except IE sometimes goes automatically to google searching for each

Nothing in the error logs
rparsons
 
Posts: 7
Joined: 26. April 2009 23:27

Re: Busy Warnings

Postby Sharley » 27. April 2009 00:18

First click on both Stop buttons in the Control Panel then close the Control Panel.

Reboot your PC.

Then what message (paste here) do you get when you run apache_start.bat file?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Busy Warnings

Postby rparsons » 27. April 2009 00:38

there are no stops on the control panel. it still says start after i start apache and mysql

i have restarted and tried to start apache and mysql with the batch files and both say they couldn't start
rparsons
 
Posts: 7
Joined: 26. April 2009 23:27

Re: Busy Warnings

Postby Sharley » 27. April 2009 00:43

rparsons wrote:i have restarted and tried to start apache and mysql with the batch files and both say they couldn't start
What is the complete message that will tell you why they won't start - paste the messages here by using the Edit menu after clicking on the little icon top right of the console window.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Busy Warnings

Postby rparsons » 27. April 2009 00:52

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
httpd.exe: Syntax error on line 42 of C:/Documents and Settings/Rob/My Documents
/Programs/xampp-win32-1.7.1/xampp/apache/conf/httpd.conf: ServerRoot must be a v
alid directory

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . .

I also just noticed that this is in the control panel
warning directory mismatch
rparsons
 
Posts: 7
Joined: 26. April 2009 23:27

Re: Busy Warnings

Postby Sharley » 27. April 2009 01:00

Run setup_xampp.bat file and try again to start MySQL and Apache.

Ignore the Directory Mismatch message as it is not important and is not affecting this issue.

If you want to get rid of the message then do a forum search using the message in the keywords box.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Busy Warnings

Postby rparsons » 27. April 2009 01:26

Thank you sooo much. Its running fine now
rparsons
 
Posts: 7
Joined: 26. April 2009 23:27


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests