what the h*ll happened?!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

what the h*ll happened?!

Postby agony » 20. April 2009 13:43

Last night i was without any issues at all working on my php project, today when i load up xampp and start apache /mysql (and all lights are green) and go to localhost ; all i get is this text (in explorer & mozilla):
Code: Select all
TTP/1.1 200 OK Date: Mon, 20 Apr 2009 12:35:33 GMT Server: Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 X-Powered-By: PHP/5.2.8 Set-Cookie: PHPSESSID=d05d33afaa86b13a24d07041b4cfe9e0; path=/ Expires: Thu, 19 Nov 1981 08:52:00 GMT Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0 Pragma: no-cache Content-Length: 441 Keep-Alive: timeout=5, max=100 Connection:
, same when i try to access localhost/phpmyadmin.

now i can't access any file through my browser, all i get is this text! :(
I am very anxious right now since im unable to access phpmyadmin and backup my databases if i were to reinstall xampp :cry:

What the heck have happened, am i beeing attacked or something?! please help me!!
I appreciate ANY thoughts/ideas!! thanks in advance guys!
agony
 
Posts: 7
Joined: 20. April 2009 13:30

Re: what the h*ll happened?!

Postby Sharley » 20. April 2009 22:43

Any clues in the xampp\apache\logs\error.log or access.log files?

After installing XAMPP is this the first time you have rebooted your PC?

Can you access using http://127.0.0.1 ?

Clear your browser's cache (Temporary Internet Files) and see if that helps.

BTW what version of XAMPP and what OS are you using?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: what the h*ll happened?!

Postby agony » 20. April 2009 22:54

Thanks for your reply!

I found nothing in either error or access.log ,and 127.0.0.1 gives exact same result.
However, it started working again after a couple of hours, i dont know why but my guess is it has to do with some session or something is beeing cached and cause this message in some way.
Because now it's the same thing again, only get that message no mather what page i try to enter. I cleared browser history/temp files & cache but still won't work.

What you think? is this some kind of session issue? :roll:

Im on win xp sp3 and xampp 1.7.0 (not a fresh install, couple of months old but never had any issues)

edit: i looked at access.log once again and now i have alot of lines saying: "GET / HTTP/1.1" 200 441" over and over again... i don't know if thats good or bad !
agony
 
Posts: 7
Joined: 20. April 2009 13:30

Re: what the h*ll happened?!

Postby Sharley » 20. April 2009 23:00

Try and delete only the session files in the xampp\tmp folder.

The session settings are in the xampp\apache\bin\php.ini file in XAMPP 1.7.0.

Your access log entry is a normal response - 200 = OK and 441 is the size of the file served in bytes.

Have you allowed cookies for localhost? also clear your cookies for localhost and try again and accept cookies when/if asked.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: what the h*ll happened?!

Postby agony » 20. April 2009 23:34

im sorry but i dont know how to allow (nor delete) cookies for localhost so i have no clue if thats on or not.
I googled it but found nothing that makes sence to me, do you know how?

And the session settings in php.ini i don't what to do with, i experimented with setting session_cache_expire to 1 minute , delete everything in xampp/tmp and restart apache and try again but no luck. Still the same :x

Thanks for helping me in this...
agony
 
Posts: 7
Joined: 20. April 2009 13:30

Re: what the h*ll happened?!

Postby Sharley » 20. April 2009 23:58

agony wrote:im sorry but i dont know how to allow (nor delete) cookies for localhost so i have no clue if thats on or not.
There is a setting in your browser that can allow or deny cookies for certain domains and a general setting that will ask you for a decision whether to allow or deny each cookie that is presented to you - For help see Firefox Help>Options>Privacy Options>Cookies
For Cookie settings in Firefox Tools>Options...>Privacy>Cookies

Internet Explorer Properties>Privacy>Advanced but I only have IE6 but new versions would be in a similar location.

agony wrote:And the session settings in php.ini i don't what to do with
Normally there should be no need to change the session settings in the php.ini file as XAMPP is designed to work out of the box for most.


This is strange as your issue has popped up after a reboot after working normally for some months.

With XP SP3 there seems to have been some issues that have been resolved by a new install as it may be that an automatic update from MS has been effected and came into play after you rebooted that has caused this hiccup.


Make a backup or Copy of xampp your current folder before uninstalling and installing the new version 1.7.1. of XAMPP for Windows - this can be deleted after the new install is successful.

If all else fails and you can't shift this annoyance it may be advisable to uninstall XAMPP by first stopping all components and removing any that are installed as a service, don't forget to close the XAMPP Control Panel before deleting the xampp folder.

Now try and use the EXE (7 zip) self extracting 1.7.1 version and extract the files to the C:\ drive which will put all the files in C:\xampp folder in their correct places.

Then run the setup_xampp.bat file to set the paths correctly.

Next open the XAMPP Control Panel - xampp-control.exe and start Apache and MySQL.

Go to http://localhost and make sure the installation is working by exercising all the demos.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: what the h*ll happened?!

Postby agony » 21. April 2009 19:43

Update: If i start everything up in xampp as normally (apache, mysql & filezilla), and then access this computer with my laptop using remote desktop, guess what, it works, and on both computers!! however the message re-apear after a while and xampp won't work until i repeat that process! how wierd is this :shock: however i am now convinced it just has to do with some session in windows that make xampp disabled after a while.... question is though.. how on earth is one supposed to fix it ?! :?
agony
 
Posts: 7
Joined: 20. April 2009 13:30

Re: what the h*ll happened?!

Postby newbie2244 » 25. April 2009 18:36

Greetings All-

I developed the same problem after testing scripts involving session vars and auth vars. To add to Sharley's comments: If you are using IE, go to the IE toolbar and select "Tools-> Internet Options-> Browsing History. After that do phpinfo() and read env var section. That will give you a clue as to what your system current state is (w/ respect to xampp) & what you may need to do.

Regards-
newbie2244
 
Posts: 49
Joined: 20. February 2009 22:39

Re: what the h*ll happened?!

Postby newbie2244 » 25. April 2009 18:41

P.S.> I forgot to mention that in my case the problem first appeared after I downloaded and tried to install WinZip32. What an awful POS! Even after I uninstalled it and thought I deleted it, parts of it are still floating in my system.
newbie2244
 
Posts: 49
Joined: 20. February 2009 22:39

Re: what the h*ll happened?!

Postby agony » 25. April 2009 20:58

That's interesting! although never got to test your tip since my issue is now solved. Gave up and reinstalled xampp as a last resort. It turned out i had alot of trojans and stuff also (maby because of the server) so it felt like i had no choice, but will definetly try that one if this problem shows up again ;)
agony
 
Posts: 7
Joined: 20. April 2009 13:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests