Cannot start Apache after upgrading 1.7.0->1.7.1 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot start Apache after upgrading 1.7.0->1.7.1 [SOLVED]

Postby yogal » 15. April 2009 22:15


Today I upgraded my XAMPP from version 1.7.0 to 1.7.1. The installation finished flawlessly, but since then i cannot start apache anymore.

I've tried:

- Starting from control panel - It goes green then immediately shuts down
The log says:
Code: Select all
Apache started [ port 80 ]

and nothing then...

- Starting from apache_start.bat file - Says:
Code: Select all
Apache 2 is starting...

then shuts down

- Starting/installing as a service - Windows gives a service error
The log from Event Monitor (translated more less accurately):
Code: Select all
The Apache 2.2 service has stopped; there has been a specific error: 1 (0x1)

As you can see, this is NOT a PORT problem:
- Portcheck reports all ports used by apache as free,
- I had a Skype conflict few weeks ago, but it has been solved since then.

I am using additional software from Zend:
- Zend Platform
- Zend Core
- Zend Optimizer (which is boundled with one of the apps mentioned above)

I suspect that installing Zend Optimizer messed up something in the httpd.conf file (which i did right after upgrading xampp since an error popped up on the Zend Platform screen, it reported Zend Optimizer as not installed despite running well for the past month or so...)

My configuration:
- Windows XP SP3
- XAMPP 1.7.1

Additional notes:
- MySQL is working ok,
- Im an not using/never had any other webserver

I hope that someone has a solution to this problem. I can only tell that my friend has a similar problem since upgrading to the newest xammp, despite running no additional/interfering software. Tell me if you need more info (logs etc) i will supply them.

Last edited by yogal on 15. April 2009 22:35, edited 1 time in total.
Posts: 2
Joined: 15. April 2009 21:53

Re: Cannot start Apache after upgrading 1.7.0->1.7.1

Postby Sharley » 15. April 2009 22:23

See if there are any clues in the xampp\apache\logs\error.log file.

Go to start>Run...
sc delete apache2.2
click OK

This may remove an old service entry from the registry that may not have been removed before doing the upgrade and will do no harm even if there is no old service entry to remove - sc.exe is the Windows Service Controller.

You may reboot after if you like then try again to start Apache.
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cannot start Apache after upgrading 1.7.0->1.7.1

Postby yogal » 15. April 2009 22:25

Thanks for the reply, deleting the service didn't help.

Sharley wrote:See if there are any clues in the xampp\apache\logs\error.log file.

Yea, I've just searched it
This is what it says:
Code: Select all
[Wed Apr 15 23:18:41 2009] [warn] pid file d:/xampp/apache/logs/ overwritten -- Unclean shutdown of previous Apache run?
[Wed Apr 15 23:18:41 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Apr 15 23:18:41 2009] [notice] Digest: done
PHP Fatal error:  [Zend Optimizer] Extension "Zend Optimizer" cannot be loaded twice in Unknown on line 0

So this is clearly a Zend Optimizer problem, i will try to tinker with it.


I have commented out everything regarding Zend Optimizer from php.ini file and now Apache works again.

However, Zend Platform cannot run without optimizer, altough it worked all right earlier. This is a problem for a diffrient forum, but could the XAMPP update anyhow mess with my extensions ?
I am marking this topic as solved though. Thanks for help.
Posts: 2
Joined: 15. April 2009 21:53

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests