XAMPP 1.6.8->1.70->1.71

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.6.8->1.70->1.71

Postby almo » 15. April 2009 16:20

Hello,

I had a working XAMPP installation. I just applied the 1.6.8 -> 1.70 update, then the 1.70 -> 1.71 update.

Now my apache installation is broken. Clicking Start from the XAMPP control panel gives "Apache service started" in the info box, but it doesn't appear to actually run. I'm thinking I need to reinstall everything, but then I have to get the srvany/Mercury thing and the apache virtual hosts and mysql DB running again from the backup I made and... :(
almo
 
Posts: 8
Joined: 18. December 2008 20:40

Re: XAMPP 1.6.8->1.70->1.71

Postby almo » 15. April 2009 16:28

Ok, ok. I found it.

"apache.exe: Syntax error on line 477 of C:/xampp/apache/conf/httpd.conf: Syntax
error on line 7 of C:/xampp/apache/conf/extra/httpd-xampp.conf: API module struc
ture 'php5_module' in file C:/xampp/apache/bin/php5apache2.dll is garbled - expe
cted signature 41503232 but saw 41503230 - perhaps this is not an Apache module
DSO, or was compiled for a different Apache version?"

Changing that to php5apache2_2.dll worked.
almo
 
Posts: 8
Joined: 18. December 2008 20:40

Re: XAMPP 1.6.8->1.70->1.71

Postby almo » 15. April 2009 16:37

But... phpmyadmin reports "Server version: 5.0.67-community-nt"

When I go to the machine itself and run mySQL, it reports "Server version: 5.1.30-community MySQL Community Server (GPL)"

Odd. I'll keep digging around, though if someone knows exactly what I've done wrong, I'd be pretty happy to hear it. :)

ETA:

More info:

From remote machine:
Server: localhost via TCP/IP
Server version: 5.0.67-community-nt
Protocol version: 10
User: root@localhost

From machine where XAMPP is installed:
Server: localhost via TCP/IP
Server version: 5.1.30-community
Protocol version: 10
User: root@localhost

:?
almo
 
Posts: 8
Joined: 18. December 2008 20:40

Re: XAMPP 1.6.8->1.70->1.71

Postby Wiedmann » 15. April 2009 17:18

phpmyadmin reports "Server version: 5.0.67-community-nt"

Clear your cookies.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: XAMPP 1.6.8->1.70->1.71

Postby almo » 15. April 2009 18:04

Wiedmann wrote:
phpmyadmin reports "Server version: 5.0.67-community-nt"

Clear your cookies.


Like, sweet. Thanks.
almo
 
Posts: 8
Joined: 18. December 2008 20:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: milaz357 and 54 guests