php problem while upgrade from 1.7.0 to 1.7.1 (Solved)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

php problem while upgrade from 1.7.0 to 1.7.1 (Solved)

Postby danielc » 15. April 2009 05:37

Hello i have tried to upgrade from 1.7.0 to 1.7.1 , using the upgrade package (Zip ), i overwrited all the files, but while tried to run apache, it said:

C:\xampp\apache\bin>apache.exe
apache.exe: Syntax error on line 480 of C:/xampp/apache/conf/httpd.conf: Syntax
error on line 7 of C:/xampp/apache/conf/extra/httpd-xampp.conf: API module struc
ture 'php5_module' in file C:/xampp/apache/bin/php5apache2.dll is garbled - expe
cted signature 41503232 but saw 41503230 - perhaps this is not an Apache module
DSO, or was compiled for a different Apache version?

what should i do now? many thanks for your help :?:
Last edited by danielc on 15. April 2009 08:58, edited 1 time in total.
danielc
 
Posts: 16
Joined: 30. December 2008 05:54

Re: php problem while upgrade from 1.7.0 to 1.7.1

Postby MoJoe » 15. April 2009 08:15

I changed following file, this works for me:

C:\xampp\apache\conf\extra\httpd-xampp.conf

out --> #LoadModule php5_module "C:/xampp/apache/bin/php5apache2.dll"
in --> LoadModule php5_module "C:/xampp/apache/bin/php5apache2_2.dll"

Greetings,
MoJoe
MoJoe
 
Posts: 7
Joined: 30. October 2008 16:06

Re: php problem while upgrade from 1.7.0 to 1.7.1

Postby danielc » 15. April 2009 08:58

work fine now, many thanks!
danielc
 
Posts: 16
Joined: 30. December 2008 05:54


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests