"SOLVED" "PUT" Support for XAMPP Lite

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: NEED "PUT" Support for XAMPP Lite

Postby steffenbaier » 20. April 2009 15:28

Hi,

has anyone got something like this working?

Steff
steffenbaier
 
Posts: 14
Joined: 14. April 2009 20:46
Location: London - United Kingdom

Re: NEED "PUT" Support for XAMPP Lite

Postby steffenbaier » 21. April 2009 17:22

OK,

I made more progress. I basically deleted everything and just started from scratch.

The only change I made this time was in the httpd.conf:

Code: Select all
<Directory "C:/xampplite/htdocs">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
    Options Indexes FollowSymLinks Includes ExecCGI


I added below the last command:

Code: Select all
Script PUT /cgi-bin/put.cgi


I added the backup.txt into

Code: Select all
C:\xampplite\htdocs


I received the following error in the Access.Log

172.27.5.130 - - [21/Apr/2009:16:54:40 +0100] "GET /backup.txt?ver=6.00+dvl-sr2+IP1200%5B08-60700.75%5D%2C+Bootcode%5B366%5D%2C+HW%5B30%5D+8192%2F32768&PROT=08-60700.75&CFG-BACKUP-NUM=1 HTTP/1.1" 200 43
172.27.5.130 - - [21/Apr/2009:16:54:40 +0100] "PUT /00-90-33-0f-23-a2.txt HTTP/1.1" 500 142


Checking the Log File from my Perl Script I could see that the Web Server of the Kirk Unit actually uploaded something but the content was checked and therefore due being empty the file was not created.

172.27.5.130 - C:\xampplite\htdocs\00-90-33-0f-23-a2.txt status 500 (Content-Length missing or zero ())


Excluding this check in the Perl Script downloaded and stored within /cgi-bin and called put.cgi:

Code: Select all
# Check we got some content
#$clength = $ENV{'CONTENT_LENGTH'};
#if (!$clength) { &reply(500, "Content-Length missing or zero ($clength)"); }


And specifying were PERL is located:

Code: Select all
#!C:/xampplite/perl/bin/perl.exe


172.27.5.130 - C:\xampplite\htdocs\00-90-33-0f-23-a2.txt status 204


Access.Log
172.27.5.130 - - [21/Apr/2009:16:55:40 +0100] "GET /backup.txt?ver=6.00+dvl-sr2+IP1200%5B08-60700.75%5D%2C+Bootcode%5B366%5D%2C+HW%5B30%5D+8192%2F32768&PROT=08-60700.75&CFG-BACKUP-NUM=1 HTTP/1.1" 200 43
172.27.5.130 - - [21/Apr/2009:16:55:40 +0100] "PUT /00-90-33-0f-23-a2.txt HTTP/1.1" 204 -


Code: Select all
 Directory of C:\xampplite\htdocs

21/04/2009  16:55    <DIR>          .
21/04/2009  16:55    <DIR>          ..
21/04/2009  17:14                 0 00-90-33-0f-23-a2.txt
steffenbaier
 
Posts: 14
Joined: 14. April 2009 20:46
Location: London - United Kingdom

Re: NEED "PUT" Support for XAMPP Lite

Postby steffenbaier » 01. May 2009 15:49

Dear all,

just an quick update on this as I got it working.

The whole PUT stuff was not needed at all !

The only change needed was the following:

Open the httpd-dav.conf from C:\xampplite\apache\conf\extra and add the following line (please be aware that part of that data is already there):

<LimitExcept PUT GET HEAD OPTIONS>

So all I had to do is add "PUT" in that line and start the server without any additional change and the script that runs on the Kirk Webserver can now store it's CFG File and loads a new Firmware if needed

Thanks

Steffen
steffenbaier
 
Posts: 14
Joined: 14. April 2009 20:46
Location: London - United Kingdom

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests