ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Problems with the Windows version of XAMPP, questions, comments, and anything related.

ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby lasha1028 » 14. April 2009 15:54

Hi Guys i want change

ErrorDocument 414 "some text" < this way it's work
but when i try
ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var don't work
ErrorDocument 414 /error.html don't work

please help me change template some attacks my server sendig GET/POST very very long i want make error 414 like 2mb file


help thanks
lasha1028
 
Posts: 13
Joined: 14. April 2009 15:49

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby Wiedmann » 14. April 2009 15:59

Code: Select all
ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var don't work

That's the default setting in XAMPP for Windows and should work out of the box in this way.

(What happens instead?)

ErrorDocument 414 /error.html don't work

You have a file "error.html" in your DocumentRoot?

(What happens instead?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby lasha1028 » 14. April 2009 16:04

Code: Select all
#
# The configuration below implements multi-language error documents through
# content-negotiation.
#
# Required modules: mod_alias, mod_include, mod_negotiation
#
# We use Alias to redirect any /error/HTTP_<error>.html.var response to
# our collection of by-error message multi-language collections.  We use
# includes to substitute the appropriate text.
#
# You can modify the messages' appearance without changing any of the
# default HTTP_<error>.html.var files by adding the line:
#
#   Alias /error/include/ "/your/include/path/"
#
# which allows you to create your own set of files by starting with the
# D:/apache/error/include/ files and copying them to /your/include/path/,
# even on a per-VirtualHost basis.  The default include files will display
# your Apache version number and your ServerAdmin email address regardless
# of the setting of ServerSignature.

Alias /error/ "C:/xampp/apache/error/"

<Directory "C:/xampp/apache/error">
    AllowOverride None
    Options IncludesNoExec
    AddOutputFilter Includes html
    AddHandler type-map var
    Order allow,deny
    Allow from all
    LanguagePriority en cs de es fr it ja ko nl pl pt-br ro sv tr
    ForceLanguagePriority Prefer Fallback
</Directory>

ErrorDocument 400 /error/HTTP_BAD_REQUEST.html.var
ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var
ErrorDocument 403 /error/HTTP_FORBIDDEN.html.var
ErrorDocument 404 /error/HTTP_NOT_FOUND.html.var
ErrorDocument 405 /error/HTTP_METHOD_NOT_ALLOWED.html.var
ErrorDocument 408 /error/HTTP_REQUEST_TIME_OUT.html.var
ErrorDocument 410 /error/HTTP_GONE.html.var
ErrorDocument 411 /error/HTTP_LENGTH_REQUIRED.html.var
ErrorDocument 412 /error/HTTP_PRECONDITION_FAILED.html.var
ErrorDocument 413 /error/HTTP_REQUEST_ENTITY_TOO_LARGE.html.var
ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var
ErrorDocument 415 /error/HTTP_UNSUPPORTED_MEDIA_TYPE.html.var
ErrorDocument 500 /error/HTTP_INTERNAL_SERVER_ERROR.html.var
ErrorDocument 501 /error/HTTP_NOT_IMPLEMENTED.html.var
ErrorDocument 502 /error/HTTP_BAD_GATEWAY.html.var
ErrorDocument 503 /error/HTTP_SERVICE_UNAVAILABLE.html.var
ErrorDocument 506 /error/HTTP_VARIANT_ALSO_VARIES.html.var
------------------------------------------------------------------------------
HTTP_REQUEST_URI_TOO_LARGE.html.var
Content-language: cs
Content-type: text/html; charset=ISO-8859-2
Body:----------cs--
<!--#set var="CONTENT_LANGUAGE" value="cs"
--><!--#set var="CHARACTER_ENCODING" value="ISO-8859-2"
--><!--#set var="TITLE" value="Po¾adované URI je pøíli¹ velké!"
--><!--#include virtual="include/top.html" -->

    Délka po¾adovaného URL pøesahuje kapacitní limit tohoto
    serveru. Po¾adavek nemù¾e být zpracován.
   
<!--#include virtual="include/bottom.html" -->
----------cs--

Content-language: de
Content-type: text/html; charset=ISO-8859-1
Body:----------de--
<!--#set var="CONTENT_LANGUAGE" value="de"
--><!--#set var="TITLE" value="&Uuml;bergebener URI zu gro&szlig;!"
--><!--#include virtual="include/top.html" -->

    Der bei der Anfrage &uuml;bermittelte URI &uuml;berschreitet
    die maximale L&auml;nge.
    Die Anfrage kann nicht ausgef&uuml;hrt werden.
   
<!--#include virtual="include/bottom.html" -->
----------de--

Content-language: en
Content-type: text/html; charset=ISO-8859-1
Body:----------en--
<!--#set var="TITLE" value="Submitted URI too large!"
--><!--#include virtual="include/top.html" -->

    The length of the requested URL exceeds the capacity limit for
   this server. The request cannot be processed.
   
<!--#include virtual="include/bottom.html" -->
----------en--

Content-language: es
Content-type: text/html; charset=ISO-8859-1
Body:----------es--
<!--#set var="CONTENT_LANGUAGE" value="es"
--><!--#set var="TITLE" value="&iexcl;Direcci&oacute;n suministrada demasiado larga!"
--><!--#include virtual="include/top.html" -->

   Su solicitud no puede procesarse debido a que la
   longitud del enlace excede la capacidad l&iacute;mite del
   servidor.
   
<!--#include virtual="include/bottom.html" -->
----------es--

Content-language: fr
Content-type: text/html; charset=ISO-8859-1
Body:----------fr--
<!--#set var="CONTENT_LANGUAGE" value="fr"
--><!--#set var="TITLE" value="L'URI demandee est trop longue!"
--><!--#include virtual="include/top.html" -->

    La longueur de l'URL demand&eacute;e exc&egrave;de la limite de
    capacit&egrave; pour ce serveur. Nous ne pouvons donner suite
    &agrave; votre requ&ecirc;te.

<!--#include virtual="include/bottom.html" -->
----------fr--

Content-language: ga
Content-type: text/html; charset=ISO-8859-1
Body:----------ga--
<!--#set var="TITLE" value="URI r&oacute;mh&oacute;r cuirthe isteach!"
--><!--#include virtual="include/top.html" -->

    T&aacute; faid an URL iarraithe breis ar an teorainn cumas don
    freastala&iacute; seo. N&iacute; f&eacute;idir an iarratas a
    phr&oacute;ise&aacute;il.

<!--#include virtual="include/bottom.html" -->
----------ga--

Content-language: it
Content-type: text/html; charset=ISO-8859-1
Body:----------it--
<!--#set var="CONTENT_LANGUAGE" value="it"
--><!--#set var="TITLE" value="URI troppo lungo!"
--><!--#include virtual="include/top.html" -->

    La lunghezza dell'indirizzo (URL) trasmesso supera il
    limite massimo imposto da questo server.
    La richiesta non pu&ograve; essere soddisfatta.

<!--#include virtual="include/bottom.html" -->
----------it--

Content-language: ja
Content-type: text/html; charset=ISO-2022-JP
Body:----------ja--
<!--#set var="CONTENT_LANGUAGE" value="ja"
--><!--#set var="CHARACTER_ENCODING" value="iso-2022-jp"
--><!--#set var="TITLE" value="Submitted URI too large!"
--><!--#include virtual="include/top.html" -->

    $B%j%/%(%9%H$N(B URL $B$ND9$5$,!"07$($kD9$5$rD6$($F$$$^$9!#(B
    $B%j%/%(%9%H$N=hM}$rB3$1$i$l$^$;$s!#(B
   
<!--#include virtual="include/bottom.html" -->
----------ja--

Content-language: ko
Content-type: text/html; charset=EUC-KR
Body:----------ko--
<!--#set var="CONTENT_LANGUAGE" value="ko"
--><!--#set var="TITLE" value="³Ê¹« ±ä URI!"
--><!--#set var="CHARACTER_ENCODING" value="EUC-KR"
--><!--#include virtual="include/top.html" -->

    ¿äûÇÑ URLÀÌ ³Ê¹« ±æ¾î¼­ ÀÌ ¼­¹ö°¡ ó¸®ÇÒ ¼ö ¾ø½À´Ï´Ù.

<!--#include virtual="include/bottom.html" -->
----------ko--

Content-language: nl
Content-type: text/html; charset=ISO-8859-1
Body:----------nl--
<!--#set var="CONTENT_LANGUAGE" value="nl"
--><!--#set var="TITLE" value="Aangeboden URI te groot!"
--><!--#include virtual="include/top.html" -->

   De lengte van de aangeboden URL overschreidt het maximum
   voor deze server. De vraag kan niet verwerkt worden.

<!--#include virtual="include/bottom.html" -->
----------nl--

Content-language: pl
Content-type: text/html; charset=ISO-8859-2
Body:----------pl--
<!--#set var="CONTENT_LANGUAGE" value="pl"
--><!--#set var="TITLE" value="Zbyt d³ugie URI!"
--><!--#set var="CHARACTER_ENCODING" value="ISO-8859-2"
--><!--#include virtual="include/top.html" -->

    D³ugo¶æ ¿±danego URLa przekracza limit ustanowiony dla tego
    serwera. ¯±danie nie mo¿e zostaæ zrealizowane.

<!--#include virtual="include/bottom.html" -->
----------pl--

Content-language: pt-br
Content-type: text/html; charset=ISO-8859-1
Body:-------pt-br--
<!--#set var="CONTENT_LANGUAGE" value="pt-br"
--><!--#set var="TITLE" value="URL excede limite!"
--><!--#include virtual="include/top.html" -->

   O tamanho do endere&ccedil;o (URL) excede a capacidade limite
   desse servidor. A requisi&ccedil;&atilde;o n&atilde;o pode ser
   processada.

<!--#include virtual="include/bottom.html" -->
-------pt-br--

Content-language: ro
Content-type: text/html; charset=ISO-8859-1
Body:----------ro--
<!--#set var="CONTENT_LANGUAGE" value="ro"
--><!--#set var="TITLE" value="URL-ul submis este prea mare!"
--><!--#include virtual="include/top.html" -->

    Lungimea URL-ului cerut depaseste limita capacitatii pentru
    acest server. Cererea nu poate fi procesata.

<!--#include virtual="include/bottom.html" -->
----------ro--

Content-language: sr
Content-type: text/html; charset=ISO-8859-5
Body:----------sr--
<!--#set var="CONTENT_LANGUAGE" value="sr"
--><!--#set var="CHARACTER_ENCODING" value="ISO-8859-5"
--><!--#set var="TITLE" value="¿ÞáÛÐâØ ÃÀ¸ øÕ ßàÕÒÕÛØÚ!"
--><!--#include virtual="include/top.html" -->

    ´ãÖØÝÐ ×ÐåâÕÒÐÝÞÓ ÃÀ»-Ð ßàÕÜÐèãøÕ ÞÓàÐÝØçÕúÐ ÜÞÓãûÝÞáâØ
    ÞÒÞÓ áÕàÒÕàÐ. ·ÐåâÕÒ ÝÕ ÜÞÖÕ ÑØâØ ÞÑàÐòÕÝ.

<!--#include virtual="include/bottom.html" -->
----------sr--

Content-language: sv
Content-type: text/html; charset=ISO-8859-1
Body:----------sv--
<!--#set var="CONTENT_LANGUAGE" value="sv"
--><!--#set var="TITLE" value="Efterfr&aring;gad URI f&ouml;r stor!"
--><!--#include virtual="include/top.html" -->

    L&auml;ngden p&aring; adressen som efterfr&aring;gas &ouml;verskrider
    kapacitetsgr&auml;nsen f&ouml;r denna server. F&ouml;rfr&aring;gan kan
    inte verkst&auml;llas.

<!--#include virtual="include/bottom.html" -->
----------sv--

Content-language: tr
Content-type: text/html; charset=ISO-8859-9
Body:----------tr--
<!--#set var="CONTENT_LANGUAGE" value="tr"
--><!--#set var="CHARACTER_ENCODING" value="ISO-8859-9"
--><!--#set var="TITLE" value="Submitted URI too large!"
--><!--#include virtual="include/top.html" -->

    Talep edilen URL'nin uzunlu&#287;u, sunucunun kapasite limitlerini a&#351;&#305;yor.
    Talep i&#351;lenemiyor.

<!--#include virtual="include/bottom.html" -->
----------tr--

so error messages is:
The length of the requested URL exceeds the capacity limit for
this server. The request cannot be processed.

now look what message my server gives me when uri too long

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>414 Request-URI Too Large</title>
</head><body>
<h1>Request-URI Too Large</h1>
<p>The requested URL's length exceeds the capacity
limit for this server.<br />
</p>
<hr>
<address>Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 Server at localhost Port 80</address>
</body></html>
< i want change this
Last edited by lasha1028 on 14. April 2009 19:38, edited 1 time in total.
lasha1028
 
Posts: 13
Joined: 14. April 2009 15:49

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby Wiedmann » 14. April 2009 16:42

Is there any question in your last post? (I know the content from this file)

BTW:
For code, you should use the Code - tags (see the buttons while you writing a post).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby lasha1028 » 14. April 2009 17:18

lats start over i want change
this :
Code: Select all
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>414 Request-URI Too Large</title>
</head><body>
<h1>Request-URI Too Large</h1>
<p>The requested URL's length exceeds the capacity
limit for this server.<br />
</p>
<hr>
<address>Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 Server at localhost Port 80</address>
</body></html>

but i don't know where this file so if somone know tell me
Last edited by lasha1028 on 14. April 2009 19:42, edited 1 time in total.
lasha1028
 
Posts: 13
Joined: 14. April 2009 15:49

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby Wiedmann » 14. April 2009 18:16

lats start over i want change this : ... but i don't know where this file so if somone know tell me

Looks like the hardcoded error messages.

If you want change this message, you can:
a) define your own error document
b) or enable "httpd-multilang-errordoc.conf" and adjust the file "HTTP_REQUEST_URI_TOO_LARGE.html.var"

(BTW 2nd time: Please use the "code" button!)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby lasha1028 » 14. April 2009 19:37

it's already enable ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var but no reaction apache has error file in other place i can't found
lasha1028
 
Posts: 13
Joined: 14. April 2009 15:49

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby Wiedmann » 14. April 2009 19:48

it's already enable ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

I don't think so:
Wiedmann wrote:Looks like the hardcoded error messages.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby lasha1028 » 14. April 2009 23:19

today i'm download xampp for windows and install default configuration coming
httpd.conf already enable
httpd-multilang-errordoc.conf < and here already enable
ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var and this message say
Code: Select all
Content-language: en
Content-type: text/html; charset=ISO-8859-1
Body:----------en--
<!--#set var="TITLE" value="Submitted URI too large!"
--><!--#include virtual="include/top.html" -->

    The length of the requested URL exceeds the capacity limit for
   this server. The request cannot be processed.
   
<!--#include virtual="include/bottom.html" -->
----------en--


now when i opening too large URI message is
Code: Select all
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>414 Request-URI Too Large</title>
</head><body>
<h1>Request-URI Too Large</h1>
<p>The requested URL's length exceeds the capacity
limit for this server.<br />
</p>
<hr>
<address>Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 Server at localhost Port 80</address>
</body></html>
lasha1028
 
Posts: 13
Joined: 14. April 2009 15:49

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby Wiedmann » 14. April 2009 23:44

OK, you are right. With an error 414, Apache is always using an internal message as error document, and not a configured URI.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby lasha1028 » 14. April 2009 23:50

:( i want answer because i need to change this error message please help

few ip attacks everyday my servers and i need big error file like 2mb

tell my if you know how i can change or tell me where get this information thankssss
lasha1028
 
Posts: 13
Joined: 14. April 2009 15:49

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby Wiedmann » 14. April 2009 23:58

i want answer

That was the answer:
Wiedmann wrote:With an error 414, Apache is always using an internal message as error document,
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby lasha1028 » 15. April 2009 00:12

so where is internal message

i can't change? :(
lasha1028
 
Posts: 13
Joined: 14. April 2009 15:49

Re: ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var

Postby Wiedmann » 15. April 2009 00:22

so where is internal message

It's defined in the Apache source code.

i can't change?

Sure:
lasha1028 wrote:ErrorDocument 414 "some text" < this way it's work

("some text" is not an URI)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests