starting XAMPP Questions

Problems with the Windows version of XAMPP, questions, comments, and anything related.

starting XAMPP Questions

Postby timp » 14. April 2009 12:49

I was able to install XAMPP to my PC successfully and have been
using it. 2 questions:
How do i change the default username(root) and password to
something else.And how do I access the MySql prompt to practice SQL
commands.
timp
 
Posts: 2
Joined: 14. April 2009 12:31

Re: starting XAMPP Questions

Postby Wiedmann » 14. April 2009 12:53

How do i change the default username(root) and password to
something else

The file "readme_en.txt" explains all.

And how do I access the MySql prompt to practice SQL
commands.

Like you can read in the MySQL Manual. The MySQL Command Line Client you can found in the directory "\xampp\mysql\bin".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: starting XAMPP Questions

Postby timp » 14. April 2009 13:07

Thanks.
timp
 
Posts: 2
Joined: 14. April 2009 12:31

Re: starting XAMPP Questions

Postby IamJim » 25. May 2009 03:37

For Wiedmann please? Or someone?

Thank-you for:
The MySQL Command Line Client you can found in the directory "\xampp\mysql\bin".


I do open fins, and run

> showdatabases;

Total db showing is only (2)
information_schema
test

in XAMPP Control panel using phpMyAdmin I have more.. 11

Please I wonder, why they do not show?

Thank-you.
IamJim
 
Posts: 56
Joined: 27. April 2009 03:01

Re: starting XAMPP Questions

Postby Wiedmann » 25. May 2009 07:20

Please I wonder, why they do not show?

The user you are using for the connection does not have enough privileges to see more.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: starting XAMPP Questions

Postby IamJim » 02. June 2009 13:19

Hello Wiedmann, and I thank-you for the reply and I am sorry about my late one. I did not have "notify response" ticked...(sigh)

Regarding your response.

Wiedmann wrote:The user you are using for the connection does not have enough privileges to see more.


OS is Windows2kServer
xampp install is from 30 days ago or so.

My local scripts I use:
Code: Select all
define("DB_SERVER", "localhost");
define("DB_USER", "root"); //change when live
define("DB_PASS", ""); // change when live


I am > cmd > cd\xampp\mysql\bin and I run command line > mysql

show databases; = Only 2

does not root , no password on localhost have FULL access?

If databases imported or created with phpMyAdmin, are they stored different? As I have 14 total.

Thank-you.

Jim

edit>> I just now went to cd\xampp\mysql\data and I see this is where ALL fro phpMyAdmin has stored these.
IamJim
 
Posts: 56
Joined: 27. April 2009 03:01

Re: starting XAMPP Questions

Postby Wiedmann » 02. June 2009 20:41

I am > cmd > cd\xampp\mysql\bin and I run command line > mysql
show databases; = Only 2
does not root , no password on localhost have FULL access?

Just using the command "mysql" in the shell, without additional parameters, connects you with an anonymous user, and not with the user "root".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: starting XAMPP Questions

Postby IamJim » 02. June 2009 20:47

Thank-you!! Now I feel like an idiot!! (smile)...as for 4-5 years now I have been working mainlyon my remote servers...... And have always, already been logged in...(as root)

Again!! My Thank's...and sorry to bother you.

Jim
IamJim
 
Posts: 56
Joined: 27. April 2009 03:01

Re: starting XAMPP Questions

Postby IamJim » 04. June 2009 12:51

Again, a problem and sorry to post it here:

Solution fine to login and access ALL db's onve I used root as user with no password.

Did it quite a few times yesterday..

Last evening I decided to upate & run SpyBot Search and Destroy.

I also rebooted this morning

Today? Unable to use command prompt to login like yesterady..

What is worse? And big problem? I try XAMPP Panel.. MySQL admin to oopen phpMyAdmin..

and now (cry)

Has anyone run across this?

Welcome to phpMyAdmin

Error
MySQL said:

Cannot connect: invalid settings.

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

IamJim
 
Posts: 56
Joined: 27. April 2009 03:01

Re: starting XAMPP Questions

Postby IamJim » 04. June 2009 13:59

Note to Wiedmann & all

RESOLVED

I am resolved, but strange situation as I stated above. All had been working fine yesterday.

a: I updated Spybot
b: I ran Spybot
c: I reboot

d: I had not run Spybot since XAMPP install, so I am not sure if??

e: Could no longer login

Had to reset mysql permissions

http://dev.mysql.com/doc/refman/5.0/en/ ... sions.html

Again, my thank's to all...but STRANGE

Jim
IamJim
 
Posts: 56
Joined: 27. April 2009 03:01


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests