Problems running xampp on Windows 2008 Server

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems running xampp on Windows 2008 Server

Postby toomanyairmiles » 13. April 2009 13:32

Hi All,
I'm having some problems getting Apache going on Win 2008 server.

I've tried altering the port using the httpd.conf file but no joy there so have returned to 80. The control panel tells me Apache is running but nothing appears on localhost or my local network ip. Any thoughts greatly appreciated - (this is for a dev machine btw).
toomanyairmiles
 
Posts: 5
Joined: 13. April 2009 12:46

Re: Problems running xampp on Windows 2008 Server

Postby morfie » 13. April 2009 21:01

toomanyairmiles, are you saying it works fine when you have Listen 80 in the .conf file but change Listen to something else it doesnt work?
morfie
 
Posts: 6
Joined: 13. April 2009 19:21

Re: Problems running xampp on Windows 2008 Server

Postby toomanyairmiles » 13. April 2009 21:45

No, it fails in either case.
toomanyairmiles
 
Posts: 5
Joined: 13. April 2009 12:46

Re: Problems running xampp on Windows 2008 Server

Postby Sharley » 13. April 2009 23:55

What do you see in your browser when you go to:
http://localhost/
http://127.0.0.1/
http://localhost/phpmyadmin


Any clues at the date and time you try and access your pages in the xampp\apache\logs\error.log or access.log files?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problems running xampp on Windows 2008 Server

Postby toomanyairmiles » 14. April 2009 01:11

http://localhost/ Nothing
http://127.0.0.1/ This works!
http://localhost/phpmyadmin Nothing

I guess the question is why would localhost not work?
toomanyairmiles
 
Posts: 5
Joined: 13. April 2009 12:46

Re: Problems running xampp on Windows 2008 Server

Postby Sharley » 14. April 2009 09:59

Open in your text editor (Notepad) C:\Windows\system32\drivers\etc\Hosts file and look for this line:
::1 localhost

Comment it out so it looks like this:
# ::1 localhost

Save the file and try again to access http://localhost/ and http://localhost/phpmyadmin

Windows Server 2008 I know nothing at all of file paths so if the Hosts file is not in the above location then do a search of your PC for the Windows Hosts file and edit accordingly.

This should have you up and running with localhost.

Please let us know if it fixes your issue,
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problems running xampp on Windows 2008 Server

Postby toomanyairmiles » 14. April 2009 14:32

Thanks for your help everyone - that got it fixed.

It would be useful to me to know why this happened though, does anyone have an explanation? Is this entry in the hosts file a windows default on the server platform or something left by other software? I've used xampp for local development a number of times but never encountered this issue before.
toomanyairmiles
 
Posts: 5
Joined: 13. April 2009 12:46

Re: Problems running xampp on Windows 2008 Server

Postby Wiedmann » 14. April 2009 14:36

Is this entry in the hosts file a windows default on the server platform or something left by other software?

It's a default for every OS, which have IPv6 enabled.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Problems running xampp on Windows 2008 Server

Postby toomanyairmiles » 14. April 2009 14:38

I see, thanks for the information will come in handy in the future, no doubt.

Thanks again to everyone who helped.
toomanyairmiles
 
Posts: 5
Joined: 13. April 2009 12:46


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests