Problems with PHP working on localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems with PHP working on localhost

Postby thesirclg » 11. April 2009 20:02

Windows Vista 64bit & Latest version of XAMPP.

I have index.php which works perfectly and shows up. Whenever I GET information via a form to test.php it doesn't return the variables.


in index.html :
Code: Select all
   <form method="get" action="test.php">
      Search DPI#:<input type="text" name="dpinum" />
      <input type="submit" />
   </form>


then in test.php:
Code: Select all

   <?php

   import_request_variables("g", "var");
   echo $vardpinum;

   
   ?>


It won't work locally. Test.php shows nothing, the variables are empty, and PHP doesn't even seem to work (attempted to test with print). Soon as I upload it to me hosted webpage it works! Any ideas why it isn't working locally but will work via my web host? Do I have something configured wrong on my end? Thanks!
thesirclg
 
Posts: 2
Joined: 11. April 2009 19:58

Re: Problems with PHP working on localhost

Postby Wiedmann » 11. April 2009 20:16

How did you open the file "index.html" in your browser?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Problems with PHP working on localhost

Postby thesirclg » 11. April 2009 20:23

Well I guess I opened it wrong ;p

I just dragged it to my firefox cause I was too lazy to type it.

I just tried it via 127.0.0.1 and it works.

Thanks ;p

/slaphead
thesirclg
 
Posts: 2
Joined: 11. April 2009 19:58


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests