Creating Virtual host

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Creating Virtual host

Postby nbalajicec » 10. April 2009 10:31

i have sucessfully created a virtual host and it's working fine and also i changed the host file.

here comes my problem,
when i type the url http://my.test.com it displays blank page.
but in the root folder of this website i placed index.php.

below is my httpd.conf file

#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#


##<VirtualHost *:80>
## ServerAdmin webmaster@dummy-host.example.com
## DocumentRoot /www/docs/dummy-host.example.com
## ServerName dummy-host.example.com
## ServerAlias http://www.dummy-host.example.com
## ErrorLog @rel_logfiledir@/dummy-host.example.com-error_log
## CustomLog @rel_logfiledir@/dummy-host.example.com-access_log common
##</VirtualHost>


<VirtualHost *:80>
DocumentRoot "D:/xampp/htdocs/"
ServerName localhost
ServerAdmin admin@scintel.com
</VirtualHost>


<VirtualHost *:80>
ServerAdmin aasquare@test.com
DocumentRoot "D:/xampp/htdocs/mytest"
ServerName local.test.com
DirectoryIndex index.php
AddType application/x-httpd-php-source .phps
AddType application/x-httpd-php .php .php5 .php4 .php3 .phtml .phpt
## ServerAlias local.scintel.com
ErrorLog "D:/xampp/htdocs/mytest/error_log/error.log"
CustomLog "D:/xampp/htdocs/mytest/error_log/common.log"common
<Directory "D:/xampp/htdocs/mytest">
Allow from all
</Directory>
</VirtualHost>


##<VirtualHost *:80>
## ServerAdmin webmaster@dummy-host2.example.com
## DocumentRoot /www/docs/dummy-host2.example.com
## ServerName dummy-host2.example.com
## ErrorLog @rel_logfiledir@/dummy-host2.example.com-error_log
## CustomLog @rel_logfiledir@/dummy-host2.example.com-access_log common
##</VirtualHost>
---
whether any other extra changes needed..

But in error log im receiving the msg like this

127.0.0.1 - - [10/Apr/2009:12:34:52 +0530] "GET /index.php HTTP/1.1" 200 -

whether this will be any problem.

Any suggestions.
nbalajicec
 
Posts: 2
Joined: 10. April 2009 09:45

Re: Creating Virtual host

Postby nbalajicec » 10. April 2009 12:20

Problem has resolved..
nbalajicec
 
Posts: 2
Joined: 10. April 2009 09:45


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 22 guests