Not all directories are showing up in root for xampp.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Not all directories are showing up in root for xampp.

Postby tommytx » 10. April 2009 02:19

Win XP pro with Xampp

For some strange reason all of my directories are not showing up on the screen.
I have the following set up..

xampp/htdocs/public_html

so:

http://localhost/public_html brings up my root directory showing both files and directories.
however i have a directory that I copied to the public_html and it does not show up so I am not able to click on it so I can click on a file inside that directory.
Also if I type in the full path when in that directory it cannot be found..

anyone have ideas that I can check..
tommytx
 
Posts: 7
Joined: 10. April 2009 02:13

Re: Not all directories are showing up in root for xampp.

Postby Sharley » 10. April 2009 07:01

First, this is the German language forum and so this topic may be moved to here:
viewforum.php?f=16

Second, it is advisable when working at localhost level to constantly clear your browser's cache - delete temporary Internet files - or you may be served a cached page not a fresh page from the server.

Third, make another folder in your public_html folder and see if it is recognized and if it is then there may be an issue with the folder you copied over, that is not been seen - right click on the folder and check the properties.

Finally, check the xampp\apache\logs\error.log file for any clues about this mystery.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Not all directories are showing up in root for xampp.

Postby tommytx » 11. April 2009 02:27

Thanks for the help, but I think I stumbled on the solution myself..
The missing directories had an htaccess file in each of them.. The darn directory will not show at all if an htaccess file is in the directory... wild...
Is there any way to use an htaccess file in the Xampp on Windows XP..
I guess there is no way to run an htaccess file on windows..

Thanks again for the help.
tommytx
 
Posts: 7
Joined: 10. April 2009 02:13

Re: Not all directories are showing up in root for xampp.

Postby Sharley » 11. April 2009 05:36

It depends on the content of the .htaccess file - if the .htaccess file is preventing indexes then you will not see a file list (index).

XAMPP uses .htaccess and .htpasswd files if you set a security password.

A .htaccess file (distributed configuration file) is simply a way of manipulating the httpd.conf file on a directory by directory basis instead of a server wide basis as for the httpd.conf file, with a few limitations.
http://httpd.apache.org/docs/2.2/howto/htaccess.html

You may also like to Google for .htaccess which will return many useful and helpful results.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Not all directories are showing up in root for xampp.

Postby Wiedmann » 11. April 2009 09:02

however i have a directory that I copied to the public_html and it does not show up ... The missing directories had an htaccess file in each of them..

That's the default behavior of mod_autoindex.
--> Just read the Apache manual how to change this.

Also if I type in the full path when in that directory it cannot be found..

So the URI (full path?) you are using in your browser is wrong.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests