Error in Config.php?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error in Config.php?

Postby FMP » 09. April 2009 14:16

Hello;

I've been trying to get ResourceSpace, a Digital Assets Management system to work. I've managed to get all the way to having that system startup the configuration pages, but when I try to take the next step, accessing the same system and logging into it, I get an error as folows:

####################################################
Sorry, an error has occured.

Please go back and try something else.

You can check your installation configuration.

C:\xampp\php\PEAR\Config.php line 80: Assigning the return value of new by reference is deprecated
####################################################

This comes from the following URL: http://localhost/montala/login.php

montala is the webroot of that system.

Is it really a problem with Config.php using an outdated method, or could it be a problem with the login script of ResourceSpace?
I'm not very experienced in seting up webservers or using PHP, hence the choice of XAMPP... it seemed the perfect choice to easily implement Montala's ResourceSpace. Please forgive my ignorance if I'm doing something basic wrong.

Thanks for any help.
FMP
 
Posts: 2
Joined: 09. April 2009 13:51

Re: Error in Config.php?

Postby Sharley » 09. April 2009 23:41

May I suggest you contact the script's author with this issue and see what they have to say about it as it may be fixable from their end - usually XAMPP will work "out of the box" for most applications with just a few that may need to be tweaked at the script code level.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error in Config.php?

Postby FMP » 14. April 2009 11:17

Hello;

Thanks for the suggestion.
Just to update on this, should anyone else feel interested...

It was something related to PEAR. Disabling PEAR eliminated this problem.
I still haven't got ResourceSpace to work properly, but now I think it's some other issue.

Thanks again.
FMP
 
Posts: 2
Joined: 09. April 2009 13:51

Re: Error in Config.php?

Postby ScoobaSteve2K1 » 06. May 2009 18:50

I'm sorry if this is a dumb question for a lot of you, but how exactly do you disable PEAR? I'm having the same issue.
ScoobaSteve2K1
 
Posts: 1
Joined: 06. May 2009 18:48

Re: Error in Config.php?

Postby Wiedmann » 06. May 2009 19:24

but how exactly do you disable PEAR?

Remove it from the include_path.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 82 guests