Error accessing phpmyadmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error accessing phpmyadmin

Postby piafma » 09. April 2009 07:27

I have installed and re-installed several times and I keep getting the following message when I try to open phpmyadmin.
I am a newbie so if you can help I would be most grateful. :|

Error
MySQL said:

#2003 - The server is not responding

Connection for controluser as defined in your configuration failed.
piafma
 
Posts: 7
Joined: 09. April 2009 07:14

Re: Error accessing phpmyadmin

Postby Sharley » 09. April 2009 08:01

First lets make sure that XAMPP is working other than the access problem with phpMyAdmin.

What do you see when you type http://localhost/ in your browser?

If you see the XAMPP Welcome Page can you click on all the demos, especially the CD Collection demo, to make sure they operate without any errors?

If all that works then we need to look at the phpMyAdmin configuration file.

Can you open C:\xampp\phpMyAdmin folder and drag this file config-inc.php into your text editor then copy and paste back here the contents, please.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error accessing phpmyadmin

Postby piafma » 09. April 2009 08:22

Thanks so much I have been up all night!!! Here is the contents of config.inc.php


<?php
/*
* This is needed for cookie based authentication to encrypt password in
* cookie
*/
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['AllowNoPasswordRoot'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

/*
* End of servers configuration
*/

?>
piafma
 
Posts: 7
Joined: 09. April 2009 07:14

Re: Error accessing phpmyadmin

Postby Sharley » 09. April 2009 08:26

You must be tired by now.

OK, seems we may have found the problem.

Open the file again and change this line:
/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';


to
/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie';


Save the file and restart Apache, then try again to access http://localhost/phpmyadmin

Also clear your browser's cache before trying to load phpMyAdmin or you may be served a cached page instead of a fresh page.


Please post back if the above fix worked so it may help others with a similar issue.
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error accessing phpmyadmin

Postby piafma » 09. April 2009 08:47

Fabulous, I'm through to phpmydmin, but is now asking for user name and password, I don't think I've created one yet
piafma
 
Posts: 7
Joined: 09. April 2009 07:14

Re: Error accessing phpmyadmin

Postby Sharley » 09. April 2009 08:51

Your user name is root and needs no password until you set one using http://localhost/security or clicking on the link in the Welcome page.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error accessing phpmyadmin

Postby piafma » 09. April 2009 09:02

sorry to be a pain again, you've been so helpful but it still won't let me in!
This is what I get

Welcome to phpMyAdmin
#2003 - The server is not responding

Log in
Username:
Password:
Connection for controluser as defined in your configuration failed.
piafma
 
Posts: 7
Joined: 09. April 2009 07:14

Re: Error accessing phpmyadmin

Postby Sharley » 09. April 2009 09:10

You have allowed cookies for localhost - 127.0.0.1?

You did not change any other settings in the config file?

You cleared your browser's cache - deleted temporary Internet files?

You have not yet set a password for user root?

Enter root for user name and leave the password field blank then click on GO.

Let me know the answers to the above questions, please.
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error accessing phpmyadmin

Postby piafma » 09. April 2009 09:15

Yes to all of the above, except I did not change any other settings in that file you told me too.
I am having a problem with the mysql service starting in the control panel.
I had something earlier saying a port was in use, but when I turned the computer on and off again it disappeared (always a great trick when you're not sure!)
piafma
 
Posts: 7
Joined: 09. April 2009 07:14

Re: Error accessing phpmyadmin

Postby Sharley » 09. April 2009 09:31

The reason that you may not be able to start MySQL is you have installed and uninstalled several times perhaps without making sure that all components were stopped and any services uninstalled first.

If you have port conflict issues then run xampp-portcheck.exe and it will tell you what is using the ports.


Try this for the MySQL issue.

Run from the mysql folder mysql_uninstallservice.bat file.

Check in the control panel that the tick is no longer in the Svc box.

Now run from a command prompt:
sc delete mysql

Next go to the mysql folder and run mysql_installservice.bat file.

Go to the control panel and check there is a tick in the Svc box and MySQL is showing that it is running - DO NOT click on the Admin... button or the world will come to an end. ;)

Hopefully you can now access phpMyAdmin.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error accessing phpmyadmin

Postby piafma » 09. April 2009 09:56

You thought that was it didn't you this is a nightmare.
When I go to run mysql_uninstallservice access is denied.

In the control panel when I unchek mysql it clicks itself back on.

A port is assigned to Mysql.

AAAAARGGh.

I have to go out now, but if you have any ideas please keep posting!!!
I know I messed things up installing and re-installing.
At one point a tutorial told me to change the root password and I did, but even that doesn't work. THat was a few installations ago though!!!
Thanks for your help....rating you as a *****
piafma
 
Posts: 7
Joined: 09. April 2009 07:14

Re: Error accessing phpmyadmin

Postby Sharley » 09. April 2009 10:01

OK, time to start afresh if you don't mind - it will perhaps clear up any mess left behind from previous installs.

I need to know what OS and what version of XAMPP, please.

I will walk you through a new install that will end up being the fix, I hope. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Error accessing phpmyadmin

Postby piafma » 10. April 2009 03:30

Hi Just to let you know I started all over again cleaning up any traces ever made of previous installs and all is now working well.
Thanks for all your help.
Pia :lol:
piafma
 
Posts: 7
Joined: 09. April 2009 07:14

Re: Error accessing phpmyadmin

Postby Sharley » 10. April 2009 06:40

piafma wrote:Hi Just to let you know I started all over again cleaning up any traces ever made of previous installs and all is now working well.
That is good news - job well done!
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests