Can only access site from my network.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can only access site from my network.

Postby anc96 » 08. April 2009 14:11

I have just set up XAMPP and and I love it. My only problem is that I can only access it from my PC's internal IP when on that network. If I try using my external IP address, I get taken to my routers page. Does anyone know how I can make my external IP take me to my XAMPP site so I can access it from anywhere?

Thanks, Alex
anc96
 
Posts: 7
Joined: 08. April 2009 14:06

Re: Can only access site from my network.

Postby jmack » 08. April 2009 14:59

Alex-

If I had to guess you need to do some routing with your...ehem...router. Have you set your router to direct all http (port 80) traffic to your local PC? Depending on your router you will have to attack this differently. It will look like:

Outside World -> your External IP -> your Router -> your PC -> xampp

Some things to remember:
1. If your PC doesn't have a static IP set on your router, I would suggest doing so. This will help keep your route working
2. Does your ISP block port 80? I doubt it since you are reaching your router, but many ISP's don't want you using port 80
3. Be sure to test this from OUTSIDE your house/work.
4. to route traffice through your router to your PC, look for things like "Port-forwarding".
5. Take a look at dyndns.org when you get things running. Your router may automatically have the capability to use this. Something for later...

I hope this gets you in the right direction,

jMack
jmack
 
Posts: 8
Joined: 14. January 2005 15:26

Re: Can only access site from my network.

Postby anc96 » 08. April 2009 16:16

its an old router. I have already tried forwarding ports 80 and 443 but still not working. I think i may need to redirect my enternal IP to localhost. Does anyone know how to do this?
anc96
 
Posts: 7
Joined: 08. April 2009 14:06

Re: Can only access site from my network.

Postby Sharley » 08. April 2009 16:30

anc96 wrote:its an old router. I have already tried forwarding ports 80 and 443 but still not working. I think i may need to redirect my enternal IP to localhost. Does anyone know how to do this?
Here's a couple of links that may help:
http://portforward.com/
http://www.pcwintech.com/node/8

Good link for setting up a server on DSL or Cable:
http://www.dslwebserver.com/main/fr_ind ... /main.html
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can only access site from my network.

Postby anc96 » 08. April 2009 18:05

Sharley wrote:
anc96 wrote:its an old router. I have already tried forwarding ports 80 and 443 but still not working. I think i may need to redirect my enternal IP to localhost. Does anyone know how to do this?
Here's a couple of links that may help:
http://portforward.com/
http://www.pcwintech.com/node/8

Good link for setting up a server on DSL or Cable:
http://www.dslwebserver.com/main/fr_ind ... /main.html


I said I have already tried forwarding the ports as I know how, but it has failed. My external IP still takes me to my router page, not my XAMPP page.
anc96
 
Posts: 7
Joined: 08. April 2009 14:06

Re: Can only access site from my network.

Postby Wiedmann » 08. April 2009 18:14

My external IP still takes me to my router page, not my XAMPP page.

You must make this access from outside your network.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can only access site from my network.

Postby anc96 » 08. April 2009 19:13

I have tried re-installing but I got the same error as the first time I installed. Could this error have something to do with it?

Ports 80 or 443(SSL) already in use! Installing Apache2.2 service failed!
anc96
 
Posts: 7
Joined: 08. April 2009 14:06

Re: Can only access site from my network.

Postby dravekx » 09. April 2009 09:07

anc96 wrote:I have tried re-installing but I got the same error as the first time I installed. Could this error have something to do with it? Ports 80 or 443(SSL) already in use! Installing Apache2.2 service failed!


First off, It's obvious you have little idea of what your doing. You cant use the following ports because they are predefined.. so stop trying to port forward them:

21: FTP (if you ever use or have one)
80: HTTP (if GIVES YOU INTERNET ACCESS)
443: HTTPS (it GIVE YOU SECURE INTERNET ACCESS)
3306: MYSQL (Usually used for your database)

need a list of common predefined ports? http://en.wikipedia.org/wiki/List_of_TC ... rt_numbers

This is a simple solution to a simple problem:

#1 SOLUTION: Go into your router and set your Computer for DMZ mode OR IP Passthrough. (Whichever is available)

OR

#2 SOLUTION: Setup your router with a port forwarding option to your PC. (Use something like PORT 8015) When you type in the address in your browser, type it like this: http://youripaddress:theportnumberyoupicked

Comments: if you have a cable modem, you need to look up CLONING your MAC Address to your computer and NOT the router. that could also be a problem.
Last edited by dravekx on 09. April 2009 09:17, edited 1 time in total.
User avatar
dravekx
 
Posts: 24
Joined: 24. January 2008 09:46
Location: Memphis, Tenn

Re: Can only access site from my network.

Postby anc96 » 09. April 2009 09:17

I misunderstood what Wiedmann said, but now I understand. If I go to my external IP from my network, I get my router page, if I go to it from a different network, then I get my site. Thank you Wiedmann!

dravekx, please don't call me stupid.
anc96
 
Posts: 7
Joined: 08. April 2009 14:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests