Cannot Start Apache Service Windows 2000

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot Start Apache Service Windows 2000

Postby AndrewKKWalker » 05. April 2009 14:08

Just tried to install XAMPP 170 onto a Windows 2000 Laptop,
to use it for local demo's
I am sure that this must be on the message board, but when I did a search I got so many hits, I could not track them all.

Issue is the Apache Cannot Start because Port 80 and 443 are in use

I ran XAMPP-CheckPort and it said that

APACHE (HTTP) Port 80 in use by C:\WINNT\System32\inetsrv\inetinfo.exe
and
APACHE (HTTPS) Port 443 in use by C:\WINNT\System32\inetsrv\inetinfo.exe

Not my laptop, so cannot just stop this, but are there any settings in config files I can change to use alternative ports?

(Currently the Apache Config file just says Listen 80)

Or would I have to stop the application that is using these ports?
If it cannot be resolved then fine, I'll just have to use a different machine for demo's.

....Just added this thought!
The laptop is running IIS so I am thinking that this might be what is causing it.
Still no wiser to alternative other than stopping IIS .


Any guidance other than pointing me to some manual to read would be good.

In the mean time I will have a look around myself for an answer
Andrew
AndrewKKWalker
 
Posts: 33
Joined: 27. March 2009 01:46
Location: Cambridge England

Re: Cannot Start Apache Service Windows 2000

Postby AndrewKKWalker » 05. April 2009 15:31

:lol: Well, I tracked down a solution that works for me.

It was IIS that was using Ports 80 and 443.

I could have shut down the IIS service, but instead changed the Config files as below

C:\xampp\apache\conf\httpd.conf:
• Search for “Listen 80″, change to “Listen 8080″
• Search for “ServerName localhost:80″, change to “ServerName localhost:8080″

C:\xampp\apache\conf\extra\httpd-ssl.conf
• Search for “Listen 443″, change to “Listen 4499″
• Search for “<VirtualHost _default_:443>”, change to “<VirtualHost _default_:4499>”
• Search for “ServerName localhost:443″, change to “ServerName localhost:4499″

'Then, you should be able to start Apache successfully through the XAMPP control panel'.



Possibly other Port Numbers might also work but I kept the suggested ones above.

Solution Courtesy http://blog.wolffmyren.com/2008/07/30/m ... s-xpvista/

May not work for all, but good enough for me!
Andrew
AndrewKKWalker
 
Posts: 33
Joined: 27. March 2009 01:46
Location: Cambridge England

Re: Cannot Start Apache Service Windows 2000

Postby AndrewKKWalker » 05. April 2009 18:06

At least ALMOST!.

Now I cannot get http://localhost to fire up XAMPP.

Must be a setting somewhere that I have to change BUT cannot find it out at the moment.
Anyone know?

In the meantime back to the searches
Andrew
AndrewKKWalker
 
Posts: 33
Joined: 27. March 2009 01:46
Location: Cambridge England

Re: Cannot Start Apache Service Windows 2000

Postby AndrewKKWalker » 06. April 2009 17:44

I've had no joy yet.

Anyone know about IIS and Apache co existing issues with localhost?

If not I need to look at other Net settings that might be the cause.

You can even point me at a manual if you must as long as it's not page 1
Andrew
AndrewKKWalker
 
Posts: 33
Joined: 27. March 2009 01:46
Location: Cambridge England

Re: Cannot Start Apache Service Windows 2000

Postby Sharley » 08. April 2009 05:48

You changed the port that Apache listens on to 8080 so from now on you must always add the port number to the address line:
http://localhost:8080/
http://mysite.com:8080/
etc.

BTW the simplest solution would have been to disable IIS in the Windows Control Panel, a forum search will reveal the simple process.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cannot Start Apache Service Windows 2000

Postby AndrewKKWalker » 08. April 2009 13:49

I'll give that a GO when I next get the Chance.

I didn't want to Disable Windows IIS, I was hoping to get them to Co exist.
I'll try the port number option to see how it works.
Andrew
AndrewKKWalker
 
Posts: 33
Joined: 27. March 2009 01:46
Location: Cambridge England

Re: Cannot Start Apache Service Windows 2000

Postby AndrewKKWalker » 09. April 2009 00:56

Did that and localhost is fine on that PC, even with IIS running.
However, now cannot get into Security.
Says that Access is denied.
Tried all the Allow 127.0.0.1 fixes and other changes to config files.
Cleared Browser Cache etc, but still no entry.
I know that there are loads of different threads on this.
All with good info, but none of which works for me at the moment, although I doubt I've read them all,
because I have other stuff to do with a higher priority.

I realise that it's all a work in progress, but there ought to be one definitive document that
covers all the configuratiopn options.
There are far too many people having similar issues for it to be simple, and we can't all be stupid.
Andrew
AndrewKKWalker
 
Posts: 33
Joined: 27. March 2009 01:46
Location: Cambridge England

Re: Cannot Start Apache Service Windows 2000

Postby Sharley » 09. April 2009 05:20

Change Allow from localhost to Allow from 127.0.0.1 in xampp\apache\conf\extra\httpd-xampp.conf file in 2 places only.

Save the file and then restart the Apache server to have those changes recognised.
(A restart of the server should always be performed when ever you edit a .conf or .ini file in XAMPP as a matter of procedure).

Try again to go to http://localhost:8080/security - you may also need to click on the Security menu item after the page loads - also these pages can take quite a while before they are loaded to allow the relevant information required to be gathered.


If that still fails you may need to comment out or delete the line:
::1 localhost - (commented looks like this # ::1 localhost)
in the C:\Windows\system32\drivers\etc\Hosts file.

Save the file and then try again.


Please realize that XAMPP is completely run, managed and maintained by people who volunteer their free time to implement and coordinate the included open source components and so, like you, there are higher priorities that will take precedence - I have seen worse from expensive commercial offerings.

There is always room for improvement in most things, even in the rowing efforts of this years losers (again). ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cannot Start Apache Service Windows 2000

Postby AndrewKKWalker » 09. April 2009 18:55

Change Allow from localhost to Allow from 127.0.0.1 in xampp\apache\conf\extra\httpd-xampp.conf file in 2 places only.


I'd already done that, but had no joy.
Will have a go at the other edit in the hosts file and report back.

:? The boat race was bad enough, don't even mention the Cricket....

I think it is s great product, and I know how much free time is put in.
But.. With so many people having similar issues, it might be good if there was a troubleshooting guide,
which detailed all the tweaks in the main config files that are needed, that could be downloaded.
It would also save a lot of postings on the message board by people like me.
Andrew
AndrewKKWalker
 
Posts: 33
Joined: 27. March 2009 01:46
Location: Cambridge England


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests

cron