Invision Power Board not working on XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Invision Power Board not working on XAMPP

Postby KingKronos » 04. April 2009 21:30

When I try to install the Invision Power Board software on XAMPP, my Apache server crashes.

Code: Select all
[Sat Apr 04 15:08:35 2009] [notice] Parent: child process exited with status 3221225477 -- Restarting.

and after starting it once more:
Code: Select all
[Sat Apr 04 15:30:00 2009] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Apr 04 15:30:00 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Apr 04 15:30:00 2009] [notice] Digest: done
[Sat Apr 04 15:30:02 2009] [notice] Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8 configured -- resuming normal operations
[Sat Apr 04 15:30:02 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat Apr 04 15:30:02 2009] [notice] Parent: Created child process 8584
[Sat Apr 04 15:30:03 2009] [notice] Digest: generating secret for digest authentication ...
[Sat Apr 04 15:30:03 2009] [notice] Digest: done
[Sat Apr 04 15:30:04 2009] [notice] Child 8584: Child process is running
[Sat Apr 04 15:30:04 2009] [notice] Child 8584: Acquired the start mutex.
[Sat Apr 04 15:30:04 2009] [notice] Child 8584: Starting 250 worker threads.
[Sat Apr 04 15:30:04 2009] [notice] Child 8584: Starting thread to listen on port 443.
[Sat Apr 04 15:30:04 2009] [notice] Child 8584: Starting thread to listen on port 80.
[Sat Apr 04 15:30:16 2009] [notice] Parent: child process exited with status 3221225477 -- Restarting.


This is all it says, but it crashed right before IPB finished installing. Any help on this?
KingKronos
 
Posts: 5
Joined: 28. February 2009 06:33

Re: Invision Power Board not working on XAMPP

Postby Wiedmann » 04. April 2009 21:36

Search the forum for problems with mysql, libmysql, pdo.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Invision Power Board not working on XAMPP

Postby KingKronos » 04. April 2009 21:46

I had a problem with pdo and libmysql once and I used this topic to fix it: viewtopic.php?f=16&t=32617
(It wasn't IPB, it was for a Php program)
KingKronos
 
Posts: 5
Joined: 28. February 2009 06:33

Re: Invision Power Board not working on XAMPP

Postby Wiedmann » 04. April 2009 22:02

(It wasn't IPB, it was for a Php program)

IPB is a PHP script.

I had a problem with pdo and libmysql once and I used this topic to fix it:

But if the solution for libmysql is not fixing this problem, I can't give more help.

(You must debug the IPB script, and find the code point which is causing the restart of the child process.3221225477 is most time an overflow in an extension or the PHP core.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Invision Power Board not working on XAMPP

Postby KingKronos » 04. April 2009 22:18

Any help on debugging then? I'm quite the php beginner, so I don't know where to start.
KingKronos
 
Posts: 5
Joined: 28. February 2009 06:33

Re: Invision Power Board not working on XAMPP

Postby Wiedmann » 04. April 2009 22:55

Any help on debugging then?

Sorry, I don't know anything about IPB.

I'm quite the php beginner, so I don't know where to start.

A good point to let the IPB support doing this job.

(It's nothing anyone can explain in a few simple sentences.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests