Set up v host, now apache won't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Set up v host, now apache won't start

Postby sharongilmore » 02. April 2009 15:16

Hi everyone,

I installed xampp yesterday, and it seemed to be working ok. Today, though, I have been trying to set up virtual hosts and seem to have broken something.

I set up the vhosts by changing the files
\xampp\apache\conf\extra\httpd-vhost.conf
and
C:\WINDOWS\system32\drivers\etc\hosts
as described here: http://drupal.org/node/161975.

Now, I can't start Apache. When I click the start button, it briefly seems to start but then stops immediately. The little window says:
Busy...
Apache started [Port 80]

I had a similar problem yesterday, which turned out to be a clash with Skye, but that's not the problem this time. I rebooted my computer and that didn't help.

Can anyone advise me?

Thanks!
Sharon
sharongilmore
 
Posts: 2
Joined: 01. April 2009 13:59

Re: Set up v host, now apache won't start

Postby Izzy » 02. April 2009 23:59

Try starting Apache with the xampp\apache_start.bat file as it will give an indication why it can't start.

You may have a problem with the syntaxt of your vhost conf file.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Set up v host, now apache won't start

Postby vincentbartol » 11. April 2009 15:19

I have the same issue, when I ran the .bat file, a message came up:

(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. :make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
vincentbartol
 
Posts: 1
Joined: 11. April 2009 15:13

Re: Set up v host, now apache won't start

Postby Sharley » 11. April 2009 23:47

Run xampp-portcheck.exe and see what is using port 443 then see if you can disable the user or change the port in apache\conf\extra\httpd-ssl.conf from 443 to 4433 for example.

Or if you are not going to use SSL (https) then comment out this line in the apache\conf\httpd.conf file:

# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf


commented out looks like this:

# Secure (SSL/TLS) connections
# Include conf/extra/httpd-ssl.conf

Save any .conf file you edit then restart Apache.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests